Bug #107319 I can't import csv file to table because Unhandled exception: 'charmap'
Submitted: 17 May 17:50 Modified: 18 May 11:52
Reporter: freddy Alc Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.29 OS:Windows (x64 bits)
Assigned to: CPU Architecture:x86 (Intel core i5)

[17 May 17:50] freddy Alc
Description:
Hi dears!
I'm trying of import a big csv file with  millions of rows to a table using MysqlWorbench 8.0.29 and I'm getting this error

============
Unhandled exception: 'charmap' codec can't decode byte 0x8d in position 7799: character maps to <undefined>
Check the log for more detail.
============
Video proof: https://youtu.be/F773id46dXI

I have converted my csv file to utf-8 codification and the problem remains, I don't know what to do, I need urgently fix this problem because I want to fill my database with data from csv files.

What should I do?

PD: My database is in utf8_general_ci 
Should I mod the my.ini file of MySQL? what should I added here?.

thanks in advance.

How to repeat:
The bug happens when I go to my databases and I select one and then right click and I select 'Table Data Import Wizard' then I just choice my csv file, next and the bug appears. Here's a video about my problem
https://youtu.be/F773id46dXI
[17 May 18:07] freddy Alc
I forgot add this log, from C:\Users\freddydev\AppData\Roaming\MySQL\Workbench\log

Here is the content of the log file: 

  File "C:\Program Files\MySQL\MySQL Workbench 8.0 CE\Python\Lib\encodings\cp1252.py", line 23, in decode
    return codecs.charmap_decode(input,self.errors,decoding_table)[0]
UnicodeDecodeError: 'charmap' codec can't decode byte 0x8d in position 7799: character maps to <undefined>
12:47:11 [INF][        WQE.net]: Shutting down SQL editor (localhost)
12:47:12 [INF][      Workbench]: Shutting down Workbench
12:47:12 [INF][ mforms managed]: Shutting down mforms wrapper
12:47:12 [INF][      Workbench]: Done
[18 May 11:14] MySQL Verification Team
Hello freddy,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with MySQL Workbench 8.0.29 and imported csv utf8 file without any issues.
Could you please provide a sample csv file which is causing this issue?

Regards,
Ashwini Patil
[18 May 11:50] freddy Alc
Maybe the problem happens because the file is 4.5 GB
[18 May 12:45] MySQL Verification Team
Successfully imported a csv file

Attachment: 107319_test_results.PNG (image/png, text), 52.39 KiB.