Bug #107259 Character Set 'utf8mb3' is not supported by .Net Framework
Submitted: 11 May 2022 9:26 Modified: 18 Dec 2023 17:26
Reporter: Matthew Khew Email Updates:
Status: Won't fix Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:8.0.29 OS:Windows
Assigned to: CPU Architecture:Any
Tags: .Net application crash, mysql upgrade issue to 8.0.29

[11 May 2022 9:26] Matthew Khew
Description:
My .NET web application is working fine with MySQL version 8.0.28 database.

After upgrading to MySQL version 8.0.29, I encountered a MySQLException error when trying to connect and read data from a table. 

The error message is "Character Set 'utf8mb3' is not supported by .Net Framework".

Nothing changes at the application side, only upgraded the MySQL version.

How to repeat:
1) Create .Net application using C# to connect to MySQL server and read data from a table.

2) .Net Framework version 4.5.1

3) MySql.Data.MySqlClient MySql.Data.Entity.EF6, Version=6.9.9.0

4) MySQL version 8.0.29
[18 May 2022 12:42] MySQL Verification Team
Hello Matthew Khew,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with MySQL 8.0.29 but I am not seeing any issues at my end.
Could you please provide repeatable test case(please make it as private if you prefer) to reproduce this issue at our end? 

Regards,
Ashwini Patil
[19 May 2022 3:51] Chris Smith
I can confirm this issue as part of 8.0.29

Using MySQL:8.0 (which is presently the 8.0.29 version) docker image, I was able to spin up a base mysql instance and then when attempting to run .NET code (RoundhousE, a .NET database deployment tool) on the database to apply schema data changes, I received the following error:

could not complete schema update
System.NotSupportedException: Character set 'utf8mb3' is not supported by .Net Framework.
   at MySql.Data.MySqlClient.CharSetMap.GetCharacterSet(DBVersion version, String charSetName)
   at MySql.Data.MySqlClient.MySqlField.SetFieldEncoding()
   at MySql.Data.MySqlClient.MySqlField.set_CharacterSetIndex(Int32 value)
   at MySql.Data.MySqlClient.NativeDriver.GetColumnData(MySqlField field)
   at MySql.Data.MySqlClient.NativeDriver.GetColumnsData(MySqlField[] columns)
   at MySql.Data.MySqlClient.Driver.GetColumns(Int32 count)
   at MySql.Data.MySqlClient.ResultSet.LoadColumns(Int32 numCols)

Upon using the MySQL:8.0.28 instance of the docker container, the above .NET code ran to completion successfully.

I attempted to run this:
1. In a Windows command prompt
2. A Powershell 7.2.4 shell
3. Ubuntu 20 LTS WSL2 Bash

dotnet SDK version is 6.0.105
 

I can provide additional details / files, as requested.
[23 May 2022 7:06] Patryk Krysik
I use Net Framework 4.5.2, MySQL Connector Net 8.0.29, MySQL for Visual Studio 1.2.8 (I try to load tables to Visual Studio 2013). The error I get is "Character set 'utf8mb3' is not supported by .Net Framework". I did convert every table to utf8mb4, the issue still subsists. It doesn't help to manually request for utf8mb4 in connection details. Every version before that worked perfectly. For now I switched for ODBC Connector but it's not perfect.
[17 Jun 2022 18:57] Bill Karwin
The default character_set_system is still utf8mb3. This is hard-coded; it is not configurable.

mysql> select version();
+-----------+
| version() |
+-----------+
| 8.0.29    |
+-----------+

mysql> select @@character_set_system;
+------------------------+
| @@character_set_system |
+------------------------+
| utf8mb3                |
+------------------------+

The system character set is used in certain fixed places, like the default character set reported for INFORMATION_SCHEMA:

mysql> show create schema information_schema\G
*************************** 1. row ***************************
       Database: information_schema
Create Database: CREATE DATABASE `information_schema` /*!40100 DEFAULT CHARACTER SET utf8mb3 */ /*!80016 DEFAULT ENCRYPTION='N' */

If a client (like .NET apparently) does some metadata checks when it connects, it could get confused by the new name for utf8. 

Ideally, the next step of migrating MySQL Server 8.0 to utf8mb4 should be to change the system character set, and any other variables or schemas that use the old character set.
[19 Jun 2022 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[19 Jun 2022 20:10] Chris Smith
Is there any information on this bug?  It seems the software you use has automatically suspended the issue, but no one has responded in any way as to if it is a.) noted on your side and b.) if it is in the queue to be fixed.

Please advise

Cheers
[19 Jun 2022 20:12] Chris Smith
I will also point out that while your software tells us that it is suspending this issue from lack of activity, and tells us we can keep the issue going by setting its status back to 'Open', there is no means by which we can set it to 'Open' (or at least there is no such means on my end.  I'm not sure if the original person who reported this can do so)
[20 Jun 2022 8:28] Patryk Krysik
@Chris Smith, as @Bill Karwin mentioned, it looks like the problem is @@character_set_system in information_schema. I do not have required permissions to change that since I'm using hosting service so I'm waiting for admin to reply. I'll add a comment if that change will help (or if they will refuse to change it). For now I just use ODBC driver and I suggest for you to do the same. It's not perfect but it's better than nothing.
[20 Jun 2022 13:35] Patryk Krysik
It looks like neither @@character_set_system and information_schema can be altered. Now we can only wait for mysql team to fix it.
[20 Jun 2022 21:49] Chris Smith
@Patryk Krysik, thanks for the fast reply.  Yeah, I noted the same myself.

As previous versions did not have this issue, for now I've rolled back to an earlier incarnation and will hold fire there until we see how this changes / gets resolved.

Cheers
[3 Jul 2022 16:56] Adam Bogart
Same experience as the others.  I created a new 8.0.29 version of mySQL (on AWS/RDS) and cannot connect due to the issue of the .NET framework not recognizing utf8mb3.  I now have to delete the instance and revert to a previous version. I'll remain on the older version as long as possible because .NET connectivity is business critical. 

This is highly concerning because this bugs breaks the tools I use regularly to access the database. If this doesn't get resolved, it will become catastrophic as we move towards the newer versions over time.
[4 Jul 2022 11:08] MySQL Verification Team
Hello Matthew,

Thank you for the report and feedback.
Verified as described.

Regards,
Ashwini Patil
[4 Jul 2022 11:09] MySQL Verification Team
8.0.29 test results

Attachment: 107259_test_results.PNG (image/png, text), 54.78 KiB.

[5 Jul 2022 20:37] Michael Caditz
Same problem here. I installed MySQL Server 8.0.29 and my .net framework 4.8 application is broken.

Amy idea when a fix can be expected?
[5 Jul 2022 20:37] Michael Caditz
Same problem here. I installed MySQL Server 8.0.29 and my .net framework 4.8 application is broken.

Amy idea when a fix can be expected?
[12 Jul 2022 4:38] Matthew Khew
Dear Ashwini Patil (MySQL Verification Team),

Great to know that you able to simulate the error in your response on 4 Jul 2022.
Please advice, the estimated release date of next patching to address this issue.

Thank you very much.

Regards,
Matthew
[27 Jul 2022 20:23] emad Mahayni
Hi,
I tested today MySQL 8.0.30 and the problem still exists.
"Character set 'utf8mb3' is not supported by .Net Framework."

I wonder when this will be fixed?

Best Regards
Emad Mahayni
[5 Aug 2022 20:56] Jordan Smith
Hey, 

We've been following this, as it's been affecting one of our applications with the same error. Are there any updates on this, please? 

Thanks,
Jord
[19 Aug 2022 14:53] Daniel Valdez
Hi,

Can you please share more information regarding your issue, e.g. MySQL Server
version, Connector/NET version, database schema?
It would help a lot to have a reproducible scenario.

Thanks,
Daniel
[26 Aug 2022 9:11] Patryk Krysik
Didn't you just upload screen of the error message we all had? What details do you need? Again: Net Framework 4.5.2, MySQL Connector Net 8.0.29, MySQL for Visual Studio 1.2.8, it happens even on newly created database with conversion to utf8mb4.
[26 Aug 2022 14:43] Daniel Valdez
Hi Patryk Krysik,

Have you tried using Connector/NET 8.0.30? I'm asking you this because there was a fix in that release that was related to the character mappings.
And also it would very helpful to know the version of the MySQL Server.

Thanks,
Daniel
[1 Sep 2022 10:35] Keso BIBO
8.0.30 also has this problem
[1 Sep 2022 17:00] Daniel Valdez
Hi @Keso BIBO

Do you have more details, like if you are using EF, EFCore, a simple .NET app, MySQL Server version, etc? I'm trying to figure it out cause it can be possible that this issue is somehow related to the server. There was an important change regarding Character Support (https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-30.html#mysqld-8-0-30-charset:~:t...).

All the cases provided above were using past releases, so if you could provide us a test case, that would really helpful for us in order to fix any possible issue.

Thanks!
[1 Sep 2022 18:24] Patryk Krysik
I confirm the problem still occurs at 8.0.30 version.
[1 Sep 2022 18:25] Patryk Krysik
I will try to provide a test case in the next week.
[1 Sep 2022 18:53] Daniel Valdez
Thanks, Patryk Krysik. That would be really appreciated.
[2 Sep 2022 5:35] Dani Kaplan
I've upgraded to 8.0.30 and I've got the same issue as well. This is pretty serious.
[20 Sep 2022 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[15 Oct 2022 12:44] Robert Nixon
Any updates on this. Seeing this error with PowerBI and a MySQL connection as well.
[15 Oct 2022 14:54] Will Tamney
Still waiting for a fix... 

After update to Mysql 8.0.29:

Toad for MySQL 8.0.0.296 (64 bit)

Character set 'utf8mb3' is not supported by .Net Framework.

System.NullReferenceException
Object reference not set to an instance of an object.
Stack Trace:
   at Quest.Toad.VersionControl.Actions.WizardIdle(BarItem item)
[17 Oct 2022 15:41] Daniel Valdez
Please try with the latest version of MySQL Server and MySQL Connector/NET, at least v8.0.30 for both products.
[17 Oct 2022 18:01] Pablo Mazza
@Daniel Valdez

You mean the latest 8.0.31? 

8.0.30 already was reported as bugged and I can confirm it throws the same error.
[17 Oct 2022 19:01] Daniel Valdez
Posted by developer:
 
Hi Pablo, 

If the error you are getting has the same signature as:

System.NotSupportedException: Character set 'utf8mb3' is not supported by
.Net Framework.
   at MySql.Data.MySqlClient.CharSetMap.GetCharacterSet(DBVersion version,
String charSetName)

Then it is still not using v8.0.30 for Connector/NET, since that "GetCharacterSet" method has been overloaded.
If you are indeed using 8.0.30 and the exception is still thrown, is there a way you could attach (mark it as private if you want) a sample project/code snippet, so we can reproduce the issue in our end.
[18 Oct 2022 9:26] Paul Cedar
Aany solution for this bug, it is still in version 8.0.31?
[18 Oct 2022 17:23] Daniel Valdez
Hi Paul Cedar,

Which version of Connector/NET are you using?
[19 Oct 2022 3:05] Paul Cedar
I am using connector/NET v8.0.31.
In addition I am using Visual Studio 2019 community edition.
[19 Oct 2022 20:10] Daniel Valdez
Posted by developer:
 
Can you share the stacktrace of the bug? If you have more information, i.e. a code snippet, that would be really helpful.
[21 Oct 2022 20:32] lee holden
This affects me too

Stacktrace to follow
[21 Oct 2022 20:49] lee holden
Stack Trace:

[NotSupportedException: Character set 'utf8mb3' is not supported by .Net Framework.]
   MySql.Data.MySqlClient.CharSetMap.GetCharacterSet(DBVersion version, String charSetName) +178
   MySql.Data.MySqlClient.MySqlField.SetFieldEncoding() +150
   MySql.Data.MySqlClient.NativeDriver.GetColumnData(MySqlField field) +356
   MySql.Data.MySqlClient.NativeDriver.GetColumnsData(MySqlField[] columns) +34
   MySql.Data.MySqlClient.Driver.GetColumns(Int32 count) +88
   MySql.Data.MySqlClient.ResultSet.LoadColumns(Int32 numCols) +22
   MySql.Data.MySqlClient.ResultSet..ctor(Driver d, Int32 statementId, Int32 numCols) +60
   MySql.Data.MySqlClient.Driver.NextResult(Int32 statementId, Boolean force) +158
   MySql.Data.MySqlClient.MySqlDataReader.NextResult() +426
   MySql.Data.MySqlClient.MySqlDataReader.Close() +138
   MySql.Data.MySqlClient.MySqlCommand.ResetReader() +48
   MySql.Data.MySqlClient.MySqlCommand.ExecuteReader(CommandBehavior behavior) +1679
   MySql.Data.MySqlClient.MySqlCommand.ExecuteDbDataReader(CommandBehavior behavior) +4
   System.Data.Common.DbCommand.ExecuteReader() +14
   WebMatrix.Data.<QueryInternal>d__0.MoveNext() +153
   System.Collections.Generic.List`1..ctor(IEnumerable`1 collection) +186
   System.Linq.Enumerable.ToList(IEnumerable`1 source) +61
   WebMatrix.Data.Database.Query(String commandText, Object[] parameters) +100
   ASP._Page_Default1_vbhtml.Execute() in D:\HostingSpaces\kettlecup\topgame.network\wwwroot\Default1.vbhtml:5
   System.Web.WebPages.WebPageBase.ExecutePageHierarchy() +198
   System.Web.WebPages.WebPage.ExecutePageHierarchy(IEnumerable`1 executors) +69
   System.Web.WebPages.WebPage.ExecutePageHierarchy() +131
   System.Web.WebPages.WebPageBase.ExecutePageHierarchy(WebPageContext pageContext, TextWriter writer, WebPageRenderingBase startPage) +78
   System.Web.WebPages.WebPageHttpHandler.ProcessRequestInternal(HttpContextBase httpContext) +116

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.8.4494.0
[21 Oct 2022 22:02] Daniel Valdez
Posted by developer:
 
Hi @Lee Holden,

As mentioned before, please ensure you're using at least v8.0.30 of MySQL Connector/NET. In the stacktrace you've shared, there's evidence that you are using a release older than v8.0.30 since the signature of the "GetCharacterSet" method, which is the one raising the exception, is not the latest.
You can take a look at our repo and validate it: https://github.com/mysql/mysql-connector-net/blob/3ebd5c49432a7bcff96438a7f9b193576acda30a...

Please upgrade the library and see if it helps.

Thanks,
Daniel Valdez
[22 Oct 2022 0:07] lee holden
Is there anywhere to download the libraries without having to compile?
[22 Oct 2022 1:08] Daniel Valdez
Posted by developer:
 
NuGet would be the suggested way to use the library or if you want, you could also download the compiled code from the official MySQL site, look for the .zip file (https://dev.mysql.com/downloads/connector/net/).
[8 Nov 2022 7:20] David Shoemaker
Visual Studio 2019 16.11.20
Installed MySql80 8.0.31
Installed Mysql-for-visualstudio 1.2.10

Open visual studio and create a project (C#, desktop, WPF).
Open the server explorer
Create a new data connection
Enter the server name "localhost"
Set the user name / password as appropriate
Test connection (should work)
Use the database name dropdown Note error:
 dialog MySql for visual studio, unable to retrieve the list of databases.

Click Advanced...
set the connection -> database to an existent database (IE Sys), click ok

In server explorer
Expand Data Connections for the just added database
Click the tables item

Note error:
Microsoft Visual Studio
---------------------------
Character set 'utf8mb3' is not supported by .Net Framework.
---------------------------
OK   
---------------------------
[8 Nov 2022 10:07] Darren Waughman
I have just experienced this issue.  Installed a brand new version of MySQL (8.0.31) and trying to talk to it via some WCF web services that were using 8.0.31 of the Connector / NET and MySQL.Data.EntityFramework (8.0.31)

Initially the WCF test tool just would not communicate with the database - and it was extremely hard to determine why.

So to simply test the connection I created data connection to the server in VS2017.  When trying to expand the tables folder, I get the error

Microsoft Visual Studio
---------------------------
Character set 'utf8mb3' is not supported by .Net Framework.
---------------------------
OK   
---------------------------

As a result of finding this thread, I changed all the individual tables to utf8mb4 and managed to get my WCF services to work - however Visual Studio will still not display the tables in the Server Explorer.

FYI - the database was set up with the Legacy Authentication Method to retain compatibility with older systems.
[14 Nov 2022 7:12] Matthew Khew
Hi MySQL Developer,

Issue still persists in version 8.0.31. Appreciate if you could fix it and update us.
[14 Nov 2022 16:08] Daniel Valdez
Posted by developer:
 
Hi Matthew Khew,

Can you share a little more info regarding your issue? MySQL Server version, Connector/NET version, .NET framework, etc. Also, if you have the stacktrace of the error, that will help.

Thanks,
Daniel
[16 Nov 2022 15:27] Daniel Valdez
Posted by developer:
 
Hi Antonio,

As mentioned in a comment above, the MySQL Connector/NET version that should be using is at least v8.0.30. Connectors are backward compatible with MySQL Server, not the other way around.

Daniel
[2 Dec 2022 9:17] Franz Roscher
Problem exists on:

MySQL version 8.0.31-0ubuntu0.20.04.2 
Connector/NET 8.0.31 (x64)
MYSQL for Visual Studio 1.2.10 (x86)

Visual Studio 2017, 2019
[6 Dec 2022 17:48] Franz Roscher
Coming (probably) closer ... 

MySQL for Visual Studio 1.2.10 installs 3 files in 

"c:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\IDE\PrivateAssemblies\.."
 
MySql.Data.dll -> 8.0.24.0
MySql.Data.EntityFramework.dll -> 8.0.24.0
MySql.Web.dll -> 8.0.24.0

With these files I get in the described error when using – during design time – Server Explorer to generate a database connection string. To be more precise – the error comers when I try to list the tables.

Contrary … the compiled version of my program runs with 8.0.31, installed via Nuget Packet Manager.

I also tried MySQL for Visual Studio 2.0.5 m4:

MySql.Data.dll -> 6.9.9.0
MySql.Data.Entity.EF6.dll -> 6.9.8.99
MySql.Web.dll  -> -> 6.9.8.99

-> With these files Vs2016 does not connect at all.

*The question is*: can the MySQL for Visual Studio 1.2.10 included files be upgraded? So far I did not find a solution.
[13 Dec 2022 7:17] Vincent Stephen
Still facing the same issue in MySQL 8.0.31 while connecting toad-for-mysql-8.0.0.296
[15 Dec 2022 18:52] Valentin Eidelman
After seeing the comment about private assemblies, I have replaced the 3 mysql DLL files in
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\IDE\PrivateAssemblies
with those of version 8.0.31
(MySql.Data.dll, MySql.Data.EntityFramework.dll, MySql.Web.dll)
at least in my case, Visual Studio stopped complaining about utf8mb3.
As a bonus, I was not able to import stored procedures into the .edmx file, the wizard would just ignore those. Now it works.
[16 Dec 2022 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[5 Jan 2023 21:46] Martin McDoangh
@Valentin Eidelman 

Sounds promising, where can I download those files? Been searching but to no avail.
[9 Jan 2023 18:45] Valentin Eidelman
@Martin McDoangh
The files are part of Connector NET https://dev.mysql.com/downloads/connector/net/
In my case, the 3 DLL files were installed under C:\Program Files (x86)\MySQL\Connector NET 8.0\Assemblies\v4.5.2
[16 Jan 2023 10:43] Franz Roscher
Unfortunately the rplacement of the files with version 8.0.31.0 did not work for me. 

Visual Studio is reporting:
=======
Could not load file or assembly 'MySql.Data, Version=8.0.24.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
=======

Has anyone an idea where VS is storing such Version information? I searched the files in "c:\Users\username\AppData\Local\Microsoft\VisualStudio" and the registry. No corresponding entries.
[24 Jan 2023 11:04] Tomáš Novák
I had the same problem. Only solution for me was downgrade SQL server (from8.0.32) to 8.0.28.
I work on Windows 10 Pro, Visual Studio 2019 16.11.23, MySQL for Visual Studio 1.2.10 and MySQL.Data 8.0.28
[27 Jan 2023 15:43] Jorge Victoria
Well ...
Year 2023. MySQL Version 8.0.32. VS 2019 ... Everything fresh installed.
The problem continues !  utf8mb3 not supported ...

I think its time to fix it !
[27 Jan 2023 16:05] Valentin Eidelman
In my case, I had to revert to version 8.0.31 because the nuget package for 8.0.32 would not install.
After reinstalling the visual studio plugin, the connector v8.0.31 and replacing the MySQL DLL files in C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\IDE\PrivateAssemblies, everything is back to normal.
In the past, when changing the version of the .net connector, the visual studio plugin would show an update dialog and ask for a restart. It is no longer the case. Maybe that is the problem?
[28 Jan 2023 4:00] Jason Martinez
I'm in the same situation, I have to use version SQL 8.0.28 for it to work!
[30 Jan 2023 12:06] Tim Reed
Code wise all is fine for me on 8.0.31, nuget installed 8.0.31, locally installed .net/connector installed 8.0.31... complies and runs.

The problem is with the Server Explorer in visual studio 2019, which i use to edit datasets etc.  MySQL for Visual Studio 1.2.10 installs mysql.data.dll version 8.0.24,  This version does not support the utf8mb3 issue and so when i try to make a new data connection i get the same error.

OK, so i can go into private assemblies, as people have suggested, and replace version 8.0.24 with version 8.0.31.  The problem is now when i try to create a new connection to MYSQL server i get the error:

Could not load file or assembly 'MySql.Data, Version=8.0.24.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d

i guess because somewhere it is pointing to this version and not the one i copied.

So for me it just seems to be the case of updating MySQL for Visual Studio to use a version of mysql.data.dll that supports the utf8mb3 issue....???
[7 Feb 2023 14:16] Joe DeForte
I installed VS 2022 and MySQL server cannot be connected to.

Went back to VS 2019 and used 8.0.32.0 Connector and the problem still exists.

Is there any resolution coming?
[7 Feb 2023 14:39] Tomáš Novák
Hi Joe, have you tried downgrade connector and (if it wont help) then server to 8.0.28?

I still wait to somebody confirm this bug as fixed, otherwise I wont update anything to keep my stuff working.
[7 Feb 2023 15:41] Joe DeForte
I have Downgraded to MySQL.Data 8.0.28 and it seems to be working.
[13 Feb 2023 8:05] nick winkley
This still exists and Microsoft have just started rolling out 8.0.31 to the MySQL managed services which breaks their own connectors from some other Azure Services. 

I have raised this with Microsoft, maybe this will force MySQL to fix this bug finally.
[13 Feb 2023 8:35] nick winkley
The latest connector/NET 8.0.32 seems to solve this issue. 

But the server is not backwards compatible, so connectors need to be updated
[15 Feb 2023 11:51] MySQL Verification Team
Bug #110070 marked as duplicate of this one
[7 Mar 2023 4:57] Vincent Stephen
I have upgraded to 8.0.32 but still facing the same issue (Character set 'utf8mb3' is not supported by .Net Framework.)
[23 May 2023 8:08] Kevin Defant
Same error on version 8.0.33
[24 May 2023 15:47] JL B. Schneider-Electric
More than one year that it is impossible to connect VS2017 & VS2019 to a MySQL Database V8 despite a working MySQL.data.dll assembly (V8.0.33 for example).

Can we please progress on this bug ?
[10 Jul 2023 12:46] Stephan Schmuck
problem still existing, running mysql server version 8.0.32
[10 Jul 2023 14:12] Stephan Schmuck
at least one could comment a work around.
use " SET character_set_results=latin1;" just before any SELECT is working for me.
[21 Aug 2023 12:41] MySQL Verification Team
Bug #112119 marked as duplicate of this one.
[21 Aug 2023 14:58] Will Tamney
One year and 3 months and still no solution: Character Set 'utf8mb3' is not supported by .Net Framework.  Maybe its time to move to level 3 support?
[21 Aug 2023 15:31] Pablo Mazza
Just to comment that the workaround suggested by Deschamps in the duplicate thread simply breaks the designer. It closes without error.

Is it that difficult to ship a new version of the .net for Visual Studio?
[11 Oct 2023 4:34] Adesh Kumar
Well

I am using MySQL version 8.0.34 and the problem still exists.

No fix till October 2023.

[ Character set 'utf8mb3' is not supported by .Net Framework. ]
[26 Oct 2023 22:45] chris south
AWS MySQL on RDS just upgraded us to 8.033 from 8.0.28 -- guessing they are upgrading everyone on RDS.  SO we have a real issue with Power Automate no longer connecting due to this issue.  Been trying to find solution all day - AWS says its MySQL issue and Microsoft says the same -- no one can fix it.

I hate to restore yesterday's database b/c it will loose all today's work -- but it appears i have no choice.....
[26 Oct 2023 22:48] chris south
ps, i updated all our application DB character_sets to utf8mb4, but still get this issue in our MS Automate functions.  Maybe system databases are the cause?
[1 Nov 2023 18:20] Will Tamney
Oracle... you need to put the "A Team" on this problem to either fix or supply a work around. Recently, Amazon has updated its MySQL instances to 8.0.33 and has broken all my client's linkages.  This has been ongoing since 5/11/2022... 1.5 years ago.  This is beyond reason.
Daniel Valdez or MySQL Verification Team or whoever... ask for some help from the third level support team.
[2 Nov 2023 12:26] chris south
Update to resolve some of our problem:
We found several utf8mb3 character sets in columns after we were upgraded by AWS to .33 -- BUT these were set to default and were NOT this character set before the conversion (we restored the DB to test and found it was clean).  So the upgrade has a bug somewhere.

Anyway,  cleaned up the few columns that had ..mb3 to ..mb4 in our application DB.  Several apps (including PowerApps) started working again.  

A few apps still could not connect (including Toad 8.0) -- guessing that some system schema's having ..mb3 are the problem.  Still trying to find workarounds or replacing apps...

SQL we used to find the problem character sets...
SELECT table_schema,  table_name, column_name, character_set_name
 FROM INFORMATION_SCHEMA.COLUMNS 
where CHARACTER_SET_NAME = 'utf8mb3'
and TABLE_SCHEMA = 'xxxxxx'
[4 Nov 2023 21:23] Pablo Mazza
Thanks for that SQL script, Chris. It solved a nasty issue I had with one of my DBs.

At this point, I guess we should not expect anything from Oracle.
[18 Dec 2023 17:26] Filipe Silva
Posted by developer:
 
MySQL Connector/NET does not support .NET Framework 4.5 any more (https://dev.mysql.com/doc/relnotes/connector-net/en/news-8-0-33.html). The lowest officially .NET Framework version supported is .NET Framework 4.8 (https://dev.mysql.com/doc/connector-net/en/connector-net-versions.html).

If you still find any issues with the supported .NET Framework versions, please re-open the bug or report a new one and provide all the information needed to reproduce it.

Thank you for your interest in MySQL Connector/NET.
[26 Jan 17:42] Steve Namuth
I think the bug may be in the CharSetMap.cs file on Github. When comparing version 8.0.28 (the version that works with utf8mb3) (https://github.com/mysql/mysql-connector-net/blob/8.0.28/MySQL.Data/src/CharSetMap.cs) the _mapping section at the bottom of the file (line 158) shows "_mapping.Add("utf8mb3", new CharacterSet("utf-8", 3));" for utf8mb3. 

However, when looking at any version past 8.0.28 (including 8.3.0 (https://github.com/mysql/mysql-connector-net/blob/8.3.0/MySQL.Data/src/CharSetMap.cs)) line 158 shows "_mapping.Add("utf8mb3", _mapping["utf8"]);"
[30 May 16:52] Will Tamney
Over 2 years and no FIX... I guess Oracle doesn't care.  Has anyone found a workaround?