Bug #105392 MySQL Workbench has encountered a problem. Parameter is not valid
Submitted: 31 Oct 2021 14:09 Modified: 2 Nov 2021 12:15
Reporter: Emmanuel Ahlidza Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.26 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[31 Oct 2021 14:09] Emmanuel Ahlidza
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\ahemm\AppData\Roaming\MySQL\Workbench\log\wb.log]
13:58:26 [INF][      Workbench]: UI is up
13:58:27 [WRN][         mforms]: Resource file not found: search_sidebar.png
13:58:33 [INF][      Workbench]: Running the application
13:58:37 [ERR][  GRTDispatcher]: exception in grt execute_task, continuing: Exception: Access denied for user 'root'@'localhost' (using password: NO)
13:58:37 [ERR][  GRTDispatcher]: worker: task 'execute sql queries' has failed with error:.Access denied for user 'root'@'localhost' (using password: NO)
13:58:45 [INF][SQL Editor Form]: Opened connection 'Local instance MySQL80' to MySQL Community Server - GPL version 8.0.26
13:58:45 [WRN][         mforms]: Resource file not found: wb-toolbar_nav-back.png
13:58:45 [WRN][         mforms]: Resource file not found: wb-toolbar_nav-forward.png
13:58:45 [WRN][         mforms]: Resource file not found: wb-toolbar_automatic-help-off.png
13:58:45 [WRN][         mforms]: Resource file not found: wb-toolbar_automatic-help-on.png
13:58:45 [WRN][         mforms]: Resource file not found: wb-toolbar_manual-help.png
13:58:46 [WRN][         mforms]: Resource file not found: snippet_use.png
13:58:46 [WRN][         mforms]: Resource file not found: snippet_insert.png
13:58:46 [WRN][         mforms]: Resource file not found: snippet_clipboard.png
14:04:02 [ERR][      Workbench]: Parameter is not valid.
Exception = System.ArgumentException
Message = Parameter is not valid.
FullText = System.ArgumentException: Parameter is not valid.
   at System.Drawing.Bitmap..ctor(String filename, Boolean useIcm)
   at TriangleNodeControl..ctor()
   at MformsTree.AddColumn(TreeColumnType type, String name, Int32 initial_width, Boolean editable)
   at mforms.MenuItem.callback(MenuItem* )
   at MenuItemEventTarget.MenuItemClick(Object sender, EventArgs e)
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Either try to access your serverby connecting to it or open Preferences in Edit option
[2 Nov 2021 12:15] MySQL Verification Team
Hello Emmanuel Ahlidza,

Thank you for the bug report.
Imho this is duplicate of Bug #99285, please see Bug #99285 and follow the suggested fix.

Regards,
Ashwini Patil