Bug #105187 Could not acquire management access in Workbench
Submitted: 11 Oct 12:31 Modified: 18 Oct 13:24
Reporter: Philippe Lévi Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:8.0.26 OS:Microsoft Windows (Win 10 21H1)
Assigned to: CPU Architecture:Any (x64)

[11 Oct 12:31] Philippe Lévi
Description:
Hi,
At least now with 8.0.26 and probably way before this, it is totally impossible to access any of the Server admin items in workbench. I keep getting the famous "Could not acquire management access for administration" error message although everything is running perfectly fine otherwaise.
Tried almost every suggestion I could find on the internet (and it seems that I'm not alone!)

- It used to work fine at the time of 8.0.20
- Nothing has changed as far as the PATH or else, besides Windows updates
- I can run chcp ok meaning that it's not a PATH issue
- I completely uninstalled everything (server, workbench, connectors), zapped the registry keys etc... and yet, no change!
- As described by many others, I get the other famous message "Error during "" : error calling Python module function WbAdmin.openAdminSection" when cancelling the first error message!
- I can testify having this issue happening on 3 different PC's where I continuously upgraded 8.x versions.

Is there anyone here having any idea as to what's going on?

Thanks

Philippe

How to repeat:
Besides reinstalling a complete new instance on a Win10 21H1 or upgrading an old install to 8.0.26, can't tell you more
[11 Oct 12:32] Philippe Lévi
Hi,
At least now with 8.0.26 and probably way before this, it is totally impossible to access any of the Server admin items in workbench. I keep getting the famous "Could not acquire management access for administration" error message although everything is running perfectly fine otherwaise.
Tried almost every suggestion I could find on the internet (and it seems that I'm not alone!)

- It used to work fine at the time of 8.0.20
- Nothing has changed as far as the PATH or else, besides Windows updates
- I can run chcp ok meaning that it's not a PATH issue
- I completely uninstalled everything (server, workbench, connectors), zapped the registry keys etc... and yet, no change!
- As described by many others, I get the other famous message "Error during "" : error calling Python module function WbAdmin.openAdminSection" when cancelling the first error message!
- I can testify having this issue happening on 3 different PC's where I continuously upgraded 8.x versions.

Is there anyone here having any idea as to what's going on?

Thanks

Philippe
[11 Oct 13:26] Philippe Lévi
Interesting experiment which (for me) seems to fix this bug:

Forgot to say that language of my initial install is French.

1. Went to Control Panel/Regional Settings/Administration
2 Change Regional Settings
3 Changed current settings from French to English(US)

and now it works!!!

Would be interesting to avoid this kind of language issue, don't you think?

I'll verify this on another machine

FWIW

Philippe
[17 Oct 14:41] Philippe Lévi
After a bit more research on the Internet and attempting to fix this on a local machine, it turns out that the steps below seem to fix it, although I really don't understand why this happens to fix it!!!
Sounds like a preloaded language issue. Remember that, in my case, this seems to happen only on my local French boxes, so I assume that this can only be seen on "non-english pristine Windows installs",...

1. Fire up Control Panel
2. Goto Regional Settings
3. Select Administration tab
4. Language for non-Unicode programs: click on Modify Regional settings and change from French to English (en-US)
5. Reboot
6 After reboot, all functions are now active again. You can then go back to Control Panel, revert "Language for non-Unicode programs" to French and everything will work fine...

Missing English language file which should be loaded or activated by default?

Up to you guys now :-)

Cheers

Philippe
[17 Oct 14:49] Philippe Lévi
Oh! And I forgot to add that the "BETA: Use UTF-8 ...." checkbox on the same dialogbox MUST ALSO BE CHECKED, otherwise the previous information is still not enough to make it work!!

Similarly, just checking the checkbox and not changing the language to English is also not functional....
[18 Oct 13:24] MySQL Verification Team
Hello Philippe Lévi,

Thank you for the bug report and feedback.
Imho this is duplicate of Bug #104973, please see Bug #104973.
This issue occurs on non-english windows installs.

Regards,
Ashwini Patil