Bug #105160 MySQL Workbench failing: Unicode relevant problems
Submitted: 7 Oct 3:02 Modified: 7 Oct 12:27
Reporter: Borun Zou Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:8.0.26 OS:Microsoft Windows (Microsoft Windows 8.1 Enterprise)
Assigned to: CPU Architecture:Any (Languageļ¼šSimplified Chinese)
Tags: WBBugReporter

[7 Oct 3:02] Borun Zou
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\CMT-Interface\AppData\Roaming\MySQL\Workbench\log\wb.log]

MySQL Workbench could not access Management-Server status, Instance-[any] and other functions giving an error
RuntimeError: Target host is configured as Windows, but seems to be a different OS. Please review the connection settings.
when system non-Unicode language is Simplified Chinese.(Other languages not tested)

Workarounds includes 1) changing system non-Unicode language to English, 2)(Windows 10) using Unicode global language support, or 3) changing an encoding config(at the end, in my case line 356, swapping utf-8 to gbk) in \MySQL\MySQL Workbench 8.0\workbench\os_utils.py or 4)to use Locale Emulator and apply a UTF workaround.

1 causes my node.js applications failing and display errors in other programs, 2 is not available on Windows 8.1 and might also affect node.js, 3 is a community workaround marked to be potentially problematic, 4 is not applicable to x64 builds.

This problem should have existed from version 8.0.23, but not in 8.0.22.

How to repeat:
On systems which its non-Unicode language is Simplified Chinese, connect to an instance and click Navigator-Management-Server status or Navigator-Instance-[any] would repeat the problem.
[7 Oct 3:26] Borun Zou
error from line 113-122

Attachment: wb.log (application/octet-stream, text), 8.16 KiB.

[7 Oct 12:27] MySQL Verification Team
Hello Borun Zou,

Thank you for the bug report.
Imho this is duplicate of Bug #104973, please see Bug #104973.

Regards,
Ashwini Patil