Bug #103207 Could not acquire management access for administration
Submitted: 5 Apr 13:21 Modified: 6 Apr 12:59
Reporter: Jerry Chen Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:8.0.23 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Service Pack 1)
Assigned to: CPU Architecture:x86
Tags: WBBugReporter

[5 Apr 13:21] Jerry Chen
Description:
MySQL_HOME = D:\Softwares\MySQL\MySQL Server 5.7

21:08:46 [ERR][SQL Editor Form]: Unable to create db_mgmt_SSHConnectionRef object
21:08:46 [ERR][wb_server_management.py:local_run_cmd_windows:407]: Exception executing local command: chcp.com: 'utf-8' codec can't decode byte 0xbb in position 0: invalid start byte
Traceback (most recent call last):
  File "D:\Softwares\MySQL\MySQL Workbench\modules\wb_server_management.py", line 404, in local_run_cmd_windows
    retcode = OSUtils.exec_command(command, output_handler)
  File "D:\Softwares\MySQL\MySQL Workbench\workbench\os_utils.py", line 360, in exec_command
    for line in iter(process.stdout.readline, ""):
  File "D:\Softwares\MySQL\MySQL Workbench\Python\Lib\codecs.py", line 322, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xbb in position 0: invalid start byte

21:08:46 [WRN][wb_server_management.py:fetch_windows_shell_info:654]: ProcessOpsWindowsLocal.fetch_windows_shell_info(): WARNING: Unable to determine codepage from shell: ""
21:08:46 [ERR][wb_server_management.py:local_run_cmd_windows:407]: Exception executing local command: ver: 'utf-8' codec can't decode byte 0xb0 in position 19: invalid start byte
Traceback (most recent call last):
  File "D:\Softwares\MySQL\MySQL Workbench\modules\wb_server_management.py", line 404, in local_run_cmd_windows
    retcode = OSUtils.exec_command(command, output_handler)
  File "D:\Softwares\MySQL\MySQL Workbench\workbench\os_utils.py", line 360, in exec_command
    for line in iter(process.stdout.readline, ""):
  File "D:\Softwares\MySQL\MySQL Workbench\Python\Lib\codecs.py", line 322, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xb0 in position 19: invalid start byte

How to repeat:
Administration->Server Status
[6 Apr 12:59] MySQL Verification Team
Hello Jerry Chen,

Thank you for the bug report.
Imho this is duplicate of Bug #102690, please see Bug #102690.

Regards,
Ashwini Patil
[22 Sep 22:56] Yue Sun
the patch to fix it:
https://github.com/mysql/mysql-workbench/pull/28