Bug #102690 Could not acquire management access for administration (Windows)
Submitted: 22 Feb 19:53 Modified: 1 Mar 12:53
Reporter: Storm Fire Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:8.0.23 OS:Microsoft Windows (Windows 10 Pro v1909 in Spanish)
Assigned to: CPU Architecture:Any (x64)

[22 Feb 19:53] Storm Fire
Description:
When I try to access the Server Status menu, Startup/Shutdown, Server Logs, Options Files, Performance Reports and Performance Schema Setup the Workbench throws this error:

Could not acquire management access for administration:

RuntimeError: Target host is configured as Windows, but seems to be a different OS. Please review the connection settings.

This has no sense because the server is being executed in the same computer (Windows)

How to repeat:
I don't think there's a particular way to reproduce this bug. It might be something to do with the version of Windows or paths, I don't know.

I have seen a bug report of another person and the MySQL Verification Team said that they didn't see any issues doing this. This is why I say I don't know how to reproduce it. Depends on something I don't know but it's there.

Link to that report: Bug #102310 (https://bugs.mysql.com/bug.php?id=102310)

Suggested fix:
I don't know. It seems to be something that occurs depending of some version or something.
[22 Feb 19:54] Storm Fire
Some images

Attachment: Image1.png (image/png, text), 57.83 KiB.

[22 Feb 19:55] Storm Fire
Another image

Attachment: Image2.png (image/png, text), 78.30 KiB.

[22 Feb 19:56] Storm Fire
Settings

Attachment: Image3.png (image/png, text), 60.15 KiB.

[22 Feb 19:58] Storm Fire
I didn't select the server that I use but the settings for the connection are the same.
[22 Feb 22:07] MySQL Verification Team
Please try to re-install with Repair option. Thanks.
[22 Feb 23:09] Storm Fire
How do I do that? I have reinstalled the Workbench and Server with the installer I have installed, but I'm not sure if it was downloaded correctly.
[22 Feb 23:22] MySQL Verification Team
Control Panel->Uninstall->Repair

Attachment: 102690.png (image/png, text), 13.47 KiB.

[22 Feb 23:23] MySQL Verification Team
To repair see prior attached screenshot.
[23 Feb 14:30] Storm Fire
It didn't work.
[1 Mar 12:53] MySQL Verification Team
Hello Storm Fire,

Thank you for the feedback. 
I still cannot repeat this issue at my end. Thanks.

Regards,
Ashwini Patil
[6 Apr 13:00] MySQL Verification Team
Bug #103207 marked as duplicate of this one.
[6 May 3:08] deyvi reyes puicon
Si no está iniciado MYSQL se debe ejecutar cmd pero como administrador.
Iniciar mysql C:\Program Files\MySQL\MySQL Server 8.0\bin>net start MYSQL80