Bug #102934 Could not find type mapping for column 'xxxx' with data type 'timestamp'. Skippi
Submitted: 11 Mar 19:28 Modified: 18 Mar 12:54
Reporter: Evgeny Prikhodko Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:3.1.10 OS:Any
Assigned to: CPU Architecture:Any

[11 Mar 19:28] Evgeny Prikhodko
Description:
Hi.

C# ConsoleApp NetCore3.1 

<PackageReference Include="Microsoft.EntityFrameworkCore" Version="3.1.12" />
<PackageReference Include="Microsoft.EntityFrameworkCore.Tools" Version="3.1.12">
  <PrivateAssets>all</PrivateAssets>
  <IncludeAssets>runtime; build; native; contentfiles; analyzers; buildtransitive</IncludeAssets>
</PackageReference>
<PackageReference Include="Microsoft.VisualStudio.Web.CodeGeneration.Design" Version="3.1.5" />
<PackageReference Include="MySql.EntityFrameworkCore" Version="3.1.10" />

How to repeat:
Scaffold-DbContext "server=127.0.0.1;database=db2;user=root;password=pasword;Allow Zero Datetime=true;Convert Zero Datetime=true" MySql.EntityFrameworkCore -Context "AppDBContext"

Message: 
Could not find type mapping for column 'xxxx' with data type 'timestamp'. Skipping column
[11 Mar 19:30] Evgeny Prikhodko
Version nuget
[15 Mar 6:55] Evgeny Prikhodko
How to solve a problem? Is there a temporary solution?
[17 Mar 13:34] MySQL Verification Team
Hello Evgeny Prikhodko,

Thank you for the bug report.
Imho this is duplicate of Bug #102381, please see Bug #102381.

Regards,
Ashwini Patil
[17 Mar 15:07] Evgeny Prikhodko
We do not understand what you are talking about.
Are you saying that it is fixed in the version that is not?

https://www.nuget.org/packages/MySql.Data.EntityFrameworkCore/ - This package has been deprecated.

https://www.nuget.org/packages/MySql.EntityFrameworkCore/ Error
[18 Mar 12:42] MySQL Verification Team
Please note that Bug #102934 is duplicate of Bug #102381 which is fixed as of the upcoming MySQL Connector/NET 8.0.24 release, and here's the proposed change log entry from the documentation team:

Several data types could not be mapped by running Scaffold-DbContext on
valid MySQL tables. This fix upgrades Microsoft Entity Framework libraries
to the latest and also adds all previously excluded mappings to the EFCore
and EFCore5 projects.
[18 Mar 12:54] Evgeny Prikhodko
MySQL Connector / NET 8.0.24 - which nuget uses it for NETCore 3.1 vs EFCore?
[17 Apr 22:24] brady moritz
This is very much still happening - I'm using .net 5.0 and the latest ef libs for mysql. 

scaffolding from inside visual studio gives errors for any "datetime" column type, it is not able to map them. 

This is the error: 
Could not find type mapping for column 'dbname.tablename.ts' with data type 'datetime'. Skipping column.
[17 Apr 22:28] brady moritz
I see in the other bug report that this is addressed in the new version to be released, is there any release date for this?
[27 Apr 13:48] Jonathan Grenier
Just installed 8.0.24 on my computer and tried again to scaffold our database. Still getting the same yellow message:
Could not find type mapping for column 'database_name.table_name.column_name' with data type 'timestamp'. Skipping column.

Currently installed:
MySQL Server 8.0.24
MySQL for Visual Studio 8.0.24
MySQL Shell 8.0.24
Connector/ODBC 8.0.24
Connector/NET 8.0.24

Also have NuGet package:
MySql.Data 8.0.24
MySql.EntityFrameworkCore 5.0.3 (says 5.0.3+MySQL8.0.24 in the version)
Microsoft.EntityFrameworkCore 5.0.5
Microsoft.EntityFrameworkCore.Relation 5.0.5

Is there anything I'm missing?

Thank you!