Bug #102038 SQL bug on Mac Big Sur
Submitted: 21 Dec 2020 10:19 Modified: 21 Dec 2020 10:41
Reporter: Araz Ibrahimov Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version: OS:Mac OS X
Assigned to: CPU Architecture:Any

[21 Dec 2020 10:19] Araz Ibrahimov
Description:
Hello,

After downloading SQL Workbench and running it on my MAC with BIG SUR OS I'm getting the following bug.

“MySQLWorkbench” can’t be opened because Apple cannot check it for malicious software. This software needs to be updated. Contact the developer for more information." 

I have downloaded the latest version of SQL Workbench. Still can't open it. Could you please help me eliminate it.

Best Regards,

Araz

How to repeat:
This could happen with everyone who updated OS in Mac.
[21 Dec 2020 10:41] MySQL Verification Team
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=101711.
[18 Jan 20:15] Sarah Draugelis
Hello! Are there any updates to this? I am unable to open as well.
[8 Feb 17:48] Yashwant Patel
no one is able to open it...not just this but other applications are also not opening....what are we supposed to do ? .....find bugs for Apple ??
[9 Feb 4:29] Jason Armstrong
This can be worked around by going to System Preferences > Security & Privacy > General > Allow the application.

v0.21 does allow Workbench to run, but 0.22 & 0.23 both immediately crash.

Having said that I cannot connect to MySQL database with Workbench on the Mac but works fine on my Windows machines (same config and credentials).

When testing connection on Mac, LuLu does not detect any outbound connection attempt.
[9 Feb 4:32] Jason Armstrong
As soon as I typed that MySQL tried to talk to my DNS provider and that was picked up by LuLu.  Once that connection was allowed the MySQL connection Test worked.  

So use archive version 0.21 and the allow to run via Security & Privacy.