Bug #101149 Modal connection dialog keeps popping after pressing Cancel
Submitted: 13 Oct 2020 9:13 Modified: 1 Feb 13:04
Reporter: Eran Eyal Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.16 OS:Mac OS X (macOS 10.14.x Mojave x86_64)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[13 Oct 2020 9:13] Eran Eyal
Description:
Modal connection dialog keeps popping after pressing Cancel. 
This effectively disables the use of the entire app, and the only thing left to do is force killing it (through Activity Monitor)

How to repeat:
1. Create a connection without storing the password in keyring
2. Wait until connection expires - a connection dialog appears, prompting to enter password.
3. Press 'Cancel' and notice how the modal dialog re-appears

Suggested fix:
Cancel button should work, i.e.: remain disconnected
[1 Feb 13:04] MySQL Verification Team
Hello Eran Eyal,

Thank you for the bug report.
This is most likely duplicate of Bug #95370, please see Bug #95370.

Regards,
Ashwini Patil