Bug #99989 Inconsistency when joining Perf Schema schema tables when PK is larger than 48 c
Submitted: 26 Jun 2020 1:06 Modified: 10 Jan 22:04
Reporter: Trey Raymond Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Performance Schema Severity:S3 (Non-critical)
Version:8.0.x, 8.0.20 OS:Any
Assigned to: CPU Architecture:Any
Tags: regression

[26 Jun 2020 1:06] Trey Raymond
Description:
re-filing this as it was closed and I can't modify it:
https://bugs.mysql.com/bug.php?id=99662&thanks=3&notify=67

it was closed asking if the requester had modified his performance schema tables, but users have no control over schema, or charset and collation, in performance_schema tables, so there's no way it could be different.  these are defined by the server.

How to repeat:
see original ticket
[26 Jun 2020 6:35] MySQL Verification Team
Hello Trey Raymond,

Thank you for the report and feedback.
Verified as described with 8.0.20 build.

regards,
Umesh
[26 Jun 2020 6:37] MySQL Verification Team
Test results - 8.0.20, 5.7.30

Attachment: 99989_8.0.20_5.7.30.results (application/octet-stream, text), 45.32 KiB.

[5 Jul 2020 11:21] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=99662 marked as duplicate of this one.
[10 Jan 22:04] Paul Dubois
Posted by developer:
 
Fixed in 8.0.23.

The Performance Schema could produce incorrect results for joins on a
CHANNEL_NAME column when the index for CHANNEL_NAME was disabled with
USE INDEX ().