Bug #99940 Stored Procedure Call parameter filling not working
Submitted: 20 Jun 2020 2:15 Modified: 9 Jul 2020 12:48
Reporter: Terry Carmen Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.16 OS:Any
Assigned to: CPU Architecture:Any

[20 Jun 2020 2:15] Terry Carmen
Description:
Selecting Stored Procedure -> Send to SQL Editor -> Procedure Call in the menu, loads the procedure call into an editor pane.

It is created with the parameters highlighted, showing data type and in/out and appears as if there were some way to fill them in without deleting all the character first, however I found no mention of it in the documentation.

I'm not sure if this an unfinished feature, or missing documentation, or just a UI that hints at something that doesn't exist.

It would be really nice to have a magic keystroke that would remove all the parameter name/type and easily fill it in with data.

If not, could the highlighting be removed so it doesn't look like there is hidden functionality that doesn't actually exist?

Any ideas?

How to repeat:
* Open Wokbench.

* Select a database

* Select "Stored Procedures"

* Right click on any procedure and select "Send to SQL Editor"

* Select "Procedure Call"

Procedure call is generated with what appear to be fillable parameters, but no obvious option to fill them and no reference to this in the docs.

Suggested fix:
Fix the documentation to explain how to use the feature, if it exists, or remove the background color that implies the feature exists.
[9 Jul 2020 12:48] MySQL Verification Team
Hello Terry Carmen,

Thank you for the reasonable feature request!

Regards,
Ashwini Patil
[1 Jun 3:58] John Mario Mayorga Forero
Please use the version 8.0.15 is the Same version that Microsoft uses on Azure Services in this 2021 year i been afected with this bug