Bug #99930 Error opening directory '/mnt': Permission denied
Submitted: 18 Jun 2020 16:03 Modified: 16 Jul 2020 11:55
Reporter: David Lévêsque Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.20 OS:Ubuntu (20.04)
Assigned to: CPU Architecture:x86

[18 Jun 2020 16:03] David Lévêsque
Got this error when browsing from system root to /mnt in the "Open Workbench Model" window.
The content and rights of directory are the following:
root@corsair:/mnt# ls -als
total 28
4 drwxrwxrwx  7 photon0 users 4096 Jun 18 11:25 .
4 drwxr-xr-x 20 photon0 users 4096 Jun 13 15:04 ..
4 drwxrwxrwx  2 photon0 users 4096 Jun 15 13:29 data
4 drwxrwxrwx  6 photon0 users 4096 Jun  9 01:58 dev
4 drwxrwxrwx  2 photon0 users 4096 Jun 15 14:01 docs
4 drwxrwxrwx  2 photon0 users 4096 Jun 15 13:28 media
4 drwxrwxrwx  2 photon0 users 4096 Jun 15 13:47 src

There are no mounted directories at the moment of test.
I even tried to disable apparmor, same result.

How to repeat:
The only root directories I can browse via Workbench are: /dev, /lib, /proc, /sys and /tmp. So, simply trying to browse to /mnt, /media or /opt should trigger the error message.
[16 Jul 2020 11:55] MySQL Verification Team
Hello David Lévêsque,

Thank you for the bug report.
I tried to reproduce your issue on Ubuntu 20.04 with workbench 8.0.20 but I am not seeing any issues at my end. 

Ashwini Patil
[16 Jul 2020 11:58] MySQL Verification Team
8.0.20 test results

Attachment: 99930_test_results.png (image/png, text), 67.78 KiB.

[4 Sep 2020 17:56] Jader Jader

I having that problem too.

I am using MysqlWorkbench installed in the same partition with the Ubuntu 20.04 (/ | ext4) and I trying to restore a backup file from other patition (/media/myUser/OtherPatition | NTFS). The other patitition (NTFS) is mounted and I can to access it using the file browser Nautilus, but I don't to access the partition NTFS using the File Opener from MysqlWorkbench.

I having that error message:
"Error opening directory'/media/myUser/myPatitionNTFS':Permission denied"

I hope that can to contribute for that question.