Bug #99804 MySql Workbench 8.0.20 Cannot Run on MacOS 10.15.5
Submitted: 8 Jun 2020 13:45 Modified: 27 Oct 2020 13:34
Reporter: Richard Collette Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.20 OS:Mac OS X (10.15.5)
Assigned to: CPU Architecture:x86
Tags: install

[8 Jun 2020 13:45] Richard Collette
Description:
When opening MySql Workbench I get

“MySQLWorkbench” can’t be opened because Apple cannot check it for malicious software.

How to repeat:
Download
Run

Suggested fix:
Sign the application appropriately.
[23 Jun 2020 21:29] Marty Ross
Caused me to ditch the product (for Sequel Pro); please fix.
[27 Jun 2020 15:19] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=100018 marked as duplicate of this one.
[10 Jul 2020 16:29] Enzo Villafuerte
I have the same problem.
[28 Jul 2020 12:27] MySQL Verification Team
Hello Richard Collette,

Thank you for the bug report.
Imho this is duplicate of Bug #99423, please see Bug #99423.

Regards,
Ashwini Patil
[27 Oct 2020 5:57] MySQL Verification Team
Hello Richard Collette,

Workaround for now is - In macOS Catalina and macOS Mojave, when an app fails to install because it hasn't been notarized or it detects that app is from an unidentified developer, it will appear in System Preferences > Security & Privacy, under the General tab. Click Open Anyway to confirm your intent to open or install the app. After this, Workbench app is now saved as an exception to your security settings, and you can open it in the future by double-clicking it, just as you can any authorized app.

Regards,
Ashwini Patil
[27 Oct 2020 13:34] Richard Collette
That workaround is not sufficient for corporate locked down desktops.

I honestly cannot believe you guys in this amount of time have not been able to resolve this issue.

I leaning toward PostgreSQL going forward.
[28 Oct 2020 5:12] MySQL Verification Team
Hello Richard Collette,

Thank you for your valuable feedback. The workaround is to allow you to use WB and actual fix is being handled as part of Bug #101328 Cannot open Benchwork App, 8.0.22, mac OS X Catalina. Since Bug #101328 is marked as private hence you cannot view and once it is fixed then your issue will be resolved. 

Thank you for your interest in MySQL.

Regards,
Ashwini Patil
[23 Dec 2020 6:58] Toluwase Thomas
why hasnt this been fixed yet?
Please fix asap
[10 Jan 23:47] Prabhu Subramanian
This is an issue for me too. Mine is OS 11 at the moment. This is not good to be not fixed this long.
[19 Jan 21:43] Jonathan Stockho
I am also having this issue.  I cannot believe Oracle hasn't fixed this in over 6 months.  Is there an eta on a fix?
[20 Jan 19:12] Peter Meyer
Same here. My system didnt allow to start the app. Why is there no fix from a big company like Oracle?
[23 Jan 13:03] Govan Komana
I'm also fighting to fix this issue too. There are no possible solutions online that works either.
[27 Jan 7:47] Lwin Htoo Ko
Even after app was allowed in Security and Privacy, it crashed when being opened.
[27 Jan 8:10] Lwin Htoo Ko
Current version is 8.0.22 but I used 8.0.20 from archive list. It worked.
[31 Jan 16:21] Abhileen Pandey
Facing the same problem in MacOS 11. When will this be resolved?
[1 Feb 23:04] K S
@Lwin Htoo Ko, this also worked for me.
[20 Feb 14:11] John Larkin
No way haha. Does this really still not work as of 2/20/2021?! As soon as I approve MySQLWorkbench from my Security and Privacy settings, it *still* crashes upon opening... Isn't Workbench used by millions of people?
[20 Feb 23:29] Jingwen Ye
Same from here, even version 8.0.23 still crashes. I've reinstalled already.
[1 Mar 2:49] Nghĩa Phạm Anh
The same for me too. 8.0.23 still crashed but it's worked with 8.0.20
[2 Mar 20:37] Claire McCallick
8.0.20 from archive list works!
[3 Mar 8:08] lon won
i can't even open MySQL Workbench 8.0.23 whilst I'm using 10.15.7
[3 Mar 8:09] lon won
i can't even open MySQL Workbench 8.0.23 whilst I'm using 10.15.7
[3 Mar 8:12] lon won
this is ridiculous, this has not to be fixed even 3/3/2021
[14 Mar 16:06] Hernán Buzzi
I'm affected by this issue as well, as MySQL Workbench 8.0.23 doesn't work on macOS Big Sur (11.2.3) due to 'Apple cannot check it for malicious software'.

The only workaround I found so far to connect to my MySQL databases is installing MySQL Workbench 8.0.15 from the versions archive, which is kind of 'old' version (dated on January 2019) but still allows the connection to DBs and manual execution of commands on them.

Hopefully a fix will be delivered soon for version 8.0.23 (or a later one), since by using old software versions we are loosing functionality which provided by other database vendors.
[18 Mar 19:29] cecilia sanchez
same problem.. crashes ... 03-18-21
[21 Mar 20:44] Simone Milanesio
same problem guys, it doesn't work..
[24 Mar 17:22] Frank Fang
same problem.. fail to open or reopen with 8.0.23, recently on 03/24/2021.

The workaround is to either use Sequel Pro, or 8.0.20 which is archived at mysql.com. I would like to thank you other folks tried earlier and shared their info, it is really useful and helpful to workaround this issue. 

BTW, after installed 8.0.20 on Mac, you might need to right click to open it instead of double click to open, a little bit tip to share.
[24 Mar 19:50] Brian Kotek
I'm not sure why this is marked as non-critical. The latest download of 8.x won't launch even if you add a security exception. And I really can't understand how this is still open after *nine months* when the problem is that you can't even *run the app*. It's kind of a big deal folks.
[1 Apr 10:48] June He
Current version is 8.0.23. Facing the same problem with Big Sur 11.0.1.
[6 Apr 23:25] Susan Fujii
Still issue on 4/6/2021 on Mac Big Sur 11.2.3.....thanks to all who recommended 8.0.20!! That works using workaround (system preferences->security & privacy->open anyway).
[7 Apr 15:59] ezequiel De Simone
version 8.0.23 crashed inclusive given the right permission. and re-installed. version 8.0.21 works for me in the new MacBook pro(not m1)
[19 Apr 13:04] Nick Franklin
8.0.23. Cannot open on Catalina. Come on guys, fix this mess.