Bug #99676 Could not get Mysqldump version : Workbench was unable to get mysqldump version.
Submitted: 24 May 2020 9:43 Modified: 22 Sep 2020 12:10
Reporter: Paul Hammond Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Workbench: Migration Severity:S3 (Non-critical)
Version:8.0.20 OS:Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[24 May 2020 9:43] Paul Hammond
No Log file was produced. The issue started happening after had I uninstalled MySQL 7 and installed MySQL 8.0.19, and then imported the database I had been using in MySQL 7. 

In an attempt to overcome the issue I scanned my PC for all the copies of mysqldump.exe and then pointed the Mysql Workbench to each of the to try and find the one that would work (using edit/preferences/Administration). None of the existing versions worked. 

I then went to a separate pc, on which I had previously successfully installed my backup and had also installed MySQL 8.0.19, to test workbench export function there and this worked fine.
I then copied the mysqldump.exe file from the PC where it was working and copied to the C:\Program Files\MySQL\MySQL Server 8.0\bin folder. When I tested the export it still failed.

In desperation I upgraded all the MySQL products from 8.0.19 to 8.0.20. Unfortunately when I then tried to run an export from mysql workbench I still received the message "Could not get Mysqldump version : Workbench was unable to get mysqldump version." Please note between each of these steps I restarted my PC. 

I have a lot of really valuable data in my data base that has taken me year to collect so I am really keen to keep it backed up.
Can you help?

How to repeat:
Executing Export from Mysql workbench generates this error but does not advise the specific details (what versions it is finding) and does not produce a log file.
[2 Jun 2020 15:25] Paul Hammond
I can see other users have had similar issues without a resolution.
[22 Sep 2020 12:10] MySQL Verification Team
Hello Paul Hammond,

Thank you for the bug report.
Imho this is duplicate of Bug #90924, please see Bug #90924 and follow the solution.

Ashwini Patil