Bug #99102 ConcurrentModificationException when using xdevapi Client with pooling
Submitted: 28 Mar 14:37 Modified: 3 Aug 21:24
Reporter: Vladimir Marinov Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / J Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any
Tags: XDevAPI

[28 Mar 14:37] Vladimir Marinov
Description:
There is no synchronization when new element is added to `com.mysql.cj.xdevapi.ClientImpl.activeProtocols`

```
public Session com.mysql.cj.xdevapi.ClientImpl.getSession() {
    ...
    this.activeProtocols.add(new WeakReference<>(prot));
    SessionImpl sess = new SessionImpl(prot);
    return sess;
}
```

How to repeat:
I do not want to supply instructions on how the bug I am reporting can be repeated, but this filed is required so...
[3 Aug 21:24] Filipe Silva
Hi Vladimir,

Thank you for this report and your interest in Connector/J.

This is a duplicate of Bug#97730.