Bug #987 mysqld got signal 11
Submitted: 3 Aug 2003 20:24 Modified: 4 Aug 2003 4:23
Reporter: [ name withheld ] Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: MyISAM storage engine Severity:S2 (Serious)
Version:4.0.12-log OS:Linux (RedHat 7.3)
Assigned to: CPU Architecture:Any

[3 Aug 2003 20:24] [ name withheld ]
Description:
OS kernel:2.4.18-27.7.xsmp #1 SMP
Our Mysql Server crash!!The following is part of it's error message.
This server never occur this kind of situation!
--------------------------------------------------------------------------------
I used pgcc to config the mysql server.
CFLAGS="-O3 -Os -mpentiumpro -mstack-align-double -fomit-frame-pointer" CXX=gcc \ 
CXXFLAGS="-O3 -Os -mpentiumpro  -mstack-align-double -fomit-frame-pointer -felide-constructors \
 -fno-exceptions -fno-rtti" ./configure \
--prefix=/usr/local --localstatedir=/home/mydb --enable-assembler \
--with-mysqld-ldflags=-all-static  --with-extra-charsets=complex \
--enable-thread-safe-client --without-debug --with-mit-threads=no --with-mysqld-user=mysql \
--with-tcp-port=3306 --with-unix-socket-path=/tmp/mysql.sock
----------------------------------------------------------------------------
030804  7:22:39  read_const: Got error 134 when reading table ./cg/tbl_skill
030804  7:22:53  read_const: Got error 134 when reading table ./cg/tbl_skill
030804  7:30:16  read_next: Got error 134 when reading table ./cg/tbl_skill
030804  7:33:51  read_const: Got error 134 when reading table ./cg/tbl_skill
030804  7:37:18  read_const: Got error 134 when reading table ./cg/tbl_skill
030804  7:40:55  read_next: Got error 134 when reading table ./cg/tbl_skill
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=1073741824
read_buffer_size=8384512
sort_buffer_size=16777208
max_used_connections=45
max_connections=200
threads_connected=21
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 1768670 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0x40c2cef8
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xbbdfc208, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
0x8083872
0x82a4448
0xbbdfc654
0x82570a9
0x8256f61
0x8256f24
0x8256f24
0x8256f24
0x825810d
0x8257f50
0x82568b0
0x80d9bcc
0x80b63a0
New value of fp=(nil) failed sanity check, terminating stack trace!

How to repeat:
The following is the result of stack track.
What happen?
------------------------------------------
0x8083872 wild_compare__FPCcN30c + 578
0x82a4448 smatcher + 648
0xbbdfc654 _end + -1281726540
0x82570a9 _nisam_get_block_info + 537
0x8256f61 _nisam_get_block_info + 209
0x8256f24 _nisam_get_block_info + 148
0x8256f24 _nisam_get_block_info + 148
0x8256f24 _nisam_get_block_info + 148
0x825810d _nisam_splitt_page + 77
0x8257f50 _nisam_insert + 464
0x82568b0 _nisam_cmp_dynamic_record + 304
0x80d9bcc str_to_TIME__FPCcUiP7st_timeb + 460
0x80b63a0 join_read_const__FP13st_join_table + 160
[4 Aug 2003 4:23] Sinisa Milivojevic
This bug report forum is mainly for repeatable bug reports. For bug
reports like this one you should use the MySQL mailing list or buy
commercial support from MySQL AB.  

(The reason for this is that we have not been able to repeat this
problem here and to find out the bug we would need to find out much
more about your system, applications, exact MySQL usage etc..)

Next, pgcc is no longer supported .

In case you can repeat a bug with our binary and non-corrupted tables , send us  a set of SQL statements that will always lead to table corruption and / or to
server crash.