Bug #9849 MySQL dies with signal 11
Submitted: 12 Apr 2005 15:56 Modified: 18 May 2005 23:41
Reporter: Iulian Nastasache Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.3 OS:Linux (Linux RHE)
Assigned to: CPU Architecture:Any

[12 Apr 2005 15:56] Iulian Nastasache
Description:
MySQL server dies with SIG 11 after about aprox. 100 -100 secs uptime, even MySQL server have no activity.

--------------------------- MySQL log: --------------------

050412 10:20:52  mysqld started
050412 10:20:52  InnoDB: Started; log sequence number 0 43655
050412 10:20:52  InnoDB: Starting recovery for XA transactions...
050412 10:20:52  InnoDB: 0 transactions in prepared state after recovery
050412 10:20:52 [Note] /usr/local/mysql/bin/mysqld: ready for connections.
Version: '5.0.3-beta-standard-log'  socket: '/tmp/mysql.sock'  port: 3306  MySQL Community Edition - Standard (GPL)
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=268435456
read_buffer_size=1044480
max_used_connections=2
max_connections=100
threads_connected=1
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 466543 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0x89cc9e0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xbfe5f6a8, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
0x8097bf3
0x8338788
0x303030
New value of fp=0x2e303639 failed sanity check, terminating stack trace!
Please read http://dev.mysql.com/doc/mysql/en/Using_stack_trace.html and follow instructions on how to resolve the stack trace. Resolved
stack trace is much more helpful in diagnosing the problem, so please do
resolve it
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at (nil)  is invalid pointer
thd->thread_id=23
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.

Number of processes running now: 0

Number of processes running now: 0
050412 10:31:16  mysqld restarted
050412 10:31:16  InnoDB: Started; log sequence number 0 43655
050412 10:31:16 [Note] Recovering after a crash using mysql-bin
050412 10:31:16 [Note] Starting crash recovery...
050412 10:31:16  InnoDB: Starting recovery for XA transactions...
050412 10:31:16  InnoDB: 0 transactions in prepared state after recovery
050412 10:31:16 [Note] Crash recovery finished.
050412 10:31:16  InnoDB: Starting recovery for XA transactions...
050412 10:31:16  InnoDB: 0 transactions in prepared state after recovery
050412 10:31:16 [Note] /usr/local/mysql/bin/mysqld: ready for connections.
Version: '5.0.3-beta-standard-log'  socket: '/tmp/mysql.sock'  port: 3306  MySQL Community Edition - Standard (GPL)

--------------------------- mysqladmin version (twice):  --------------------
/usr/local/mysql/bin/mysqladmin  Ver 8.41 Distrib 5.0.3-beta, for pc-linux-gnu on i686
Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL license

Server version          5.0.3-beta-standard-log
Protocol version        10
Connection              Localhost via UNIX socket
UNIX socket             /tmp/mysql.sock
Uptime:                 10 min 24 sec

Threads: 1  Questions: 170  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -8749677420012629010043242724009880733055839004435945613340707846787494172240928659796656400221776985188892432411697508943452919050762600297776051693818764853496949042321847768248067632713008971225869091684080105714048845024611572207981186369518185449254273862800770895666216960.000

/usr/local/mysql/bin/mysqladmin  Ver 8.41 Distrib 5.0.3-beta, for pc-linux-gnu on i686
Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL license

Server version          5.0.3-beta-standard-log
Protocol version        10
Connection              Localhost via UNIX socket
UNIX socket             /tmp/mysql.sock
Uptime:                 47 sec

Threads: 2  Questions: 135  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000

--------------------------- mysqladmin status (a while):  --------------------

Uptime: 716  Threads: 2  Questions: 3079  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 373615946539697022057745982904386934624047441931780749486189671255397380517195931350486873691127289992576155001670702692012453138273918901958588927684455817415654082730299737452389075784495033578219946037975726424064.000
Uptime: 721  Threads: 3  Questions: 3114  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 28171559028629513086346759145254421758921457717101631859851264.000
Uptime: 726  Threads: 2  Questions: 3140  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -339900270656640592856443256773199591195380386144518156407683258919619457339153784349281688847871955186743048143253328347329986560.000
Uptime: 731  Threads: 3  Questions: 3167  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 3570780864512.004
Uptime: 736  Threads: 3  Questions: 3194  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 568238530827779451736817885275108541952189324019785942311478731508429445793532939048139679022356618440811339056415074330128773086601357306298695752350154175586921638365611765166424335283081826014065832790569245034271156638886721862756861682092972874694779788017448314230253748748288.000
Uptime: 5  Threads: 2  Questions: 27  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 10  Threads: 4  Questions: 62  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -92559641157289369920794959898346230464984201177585795660251136.000
Uptime: 15  Threads: 2  Questions: 110  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 11945302443632255153476868443695408274615571292628957190035137601487501216325910342976529617766970294272.000
Uptime: 20  Threads: 3  Questions: 145  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 25  Threads: 2  Questions: 186  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 9070949719158513858247210855626842430364205215983915877001858738078704163829704844328089647029427873599881475832877572306756942438596608.000
Uptime: 30  Threads: 2  Questions: 212  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 747707876334373830656.000

-------------------- Notes -------------------
- I use standard my.cnf file for large systems (I tested also with some different variables about buffer and timeout, with same result)

- Here is resolve_stack_dump result:

0x8097bf3 handle_segfault + 423
0x8338788 pthread_sighandler + 184
0x80a7bf9 dispatch_command__F19enum_server_commandP3THDPcUi + 4925
0x36313935 _end + 768410553

How to repeat:
I used a fresh installation of mysql-binary 5.0.3-beta in a new Linux RHE system, and just started MySQL. After a while, even if very low  MySQL server activity (ie using mysqladmin version) I got above errors in log (about aprox 100-1000 sec uptime, that error is repeated, see mysqladmin stats above)

Suggested fix:
I don't know if that is related with wrong displaying of Queries per second avg (this is an separated bug here on list)
[12 Apr 2005 17:44] Jorge del Conde
Hi!

Can you please give me step by step instructions on how to reproduce this bug ?  Also, please upload your my.cnf (or my.ini) file so that we can take a look at it.

THanks.
[13 Apr 2005 12:25] Iulian Nastasache
test with my.cnf-medium (only uncommented innodb vars and change innodb_log_file_size to 64MB)

Attachment: my.cnf.1 (application/octet-stream, text), 4.79 KiB.

[13 Apr 2005 12:26] Iulian Nastasache
test with my.cnf-large (only uncommented innodb vars)

Attachment: my.cnf.2 (application/octet-stream, text), 4.78 KiB.

[13 Apr 2005 12:27] Iulian Nastasache
test with my.cnf-custom

Attachment: my.cnf.3 (application/octet-stream, text), 5.17 KiB.

[13 Apr 2005 14:04] Iulian Nastasache
Hi

See uploaded my.cnf files (I tested with 3 different with same result)

Unfortunatelly, about how to reproduce this posible bug I have nothing too much to say because I just installed and start mysql. I write bellow some info and steps to install mysql and get bug on RHE, as I have reproduced the bug. An important info is that I tested also on a RH9 distribution, on other similar machine, with same result. 
Currently I can't reproduce the bug from the scratch because I use now an application there (even I can't suspect my application, and end bellow is also included queries used currently, maybe help you).
----------------------------------
1. Get a new distribution of RHE and do rpm -e for all mysql.

2. Install mysql binary (common way by INSTALL from mysql-standard-5.0.3-beta-pc-linux-gnu-i686.tar.gz)
groupadd mysql
useradd -g mysql mysql
gunzip < /var/local/src/dist/030/mysql-standard-5.0.3-beta-pc-linux-gnu-i686.tar.gz | tar xvf -
ln -s mysql-standard-5.0.3-beta-pc-linux-gnu-i686 mysql
cd mysql
scripts/mysql_install_db --user=mysql
chown -R root  .
chown -R mysql data
chgrp -R mysql .
cp /usr/local/mysql/support-files/my-large.cnf /etc/my.cnf
mcedit /etc/my.cnf (uncomment innodb vars)
cd /usr/local/mysql

3. Starting MySQL server

cp /usr/local/mysql/support-files/mysql.server /etc/rc.d/init.d/mysql

(note - at this point, mysql.server from binary distribution is not working, with error "Can't execute @sbindir@/mysqlmanager", so I used mysql.server old format from 4.0.20; this I don't think have importance - bug exist even I starting mysql manually by using "/usr/local/mysql/bin/mysqld_safe --user=mysql"
note - maybe this help you more - when I starting MySQL server using mysqld_safe as above, I got next info by a while:

/usr/local/mysql/bin/mysqld_safe --user=mysql

Starting mysqld daemon with databases from /usr/local/mysql/data

Number of processes running now: 0
050413 07:56:43  mysqld restarted

Number of processes running now: 0
050413 07:59:14  mysqld restarted

Number of processes running now: 0
050413 08:00:04  mysqld restarted

Number of processes running now: 0
050413 08:09:20  mysqld restarted

Number of processes running now: 0
050413 08:10:15  mysqld restarted

Number of processes running now: 0
050413 08:11:25  mysqld restarted

Number of processes running now: 0
050413 08:12:10  mysqld restarted
/usr/local/mysql/bin/mysqld_safe: line 1: 13982 Segmentation fault      nohup /usr/local/mysql/bin/mysqld --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data --user=mysql --pid-file=/usr/local/mysql/data/sm03.pid --skip-locking --port=3306 --socket=/tmp/mysql.sock >>/usr/local/mysql/data/sm03.err 2>&1

)

chmod 744 /etc/rc.d/init.d/mysql
chkconfig --add mysql
/etc/rc.d/init.d/mysql start

4. Launching mysqladmin:
/usr/local/mysql/bin/mysqladmin -ppassword -i 5 -r status (or simple mysqladmin version)
and watch result.
Result is (sorry for long posting, I show here 2 "restarting of mysqld"):

Uptime: 13  Threads: 2  Questions: 37  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 288811588040601530715257875202745641039831820528797278175419603500400640.000
Uptime: 18  Threads: 1  Questions: 38  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 23  Threads: 1  Questions: 38  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -2236446779560301085766931401656692076074418030415168157174999012060186365730829461918884328042912842644113648354198809001506764305192281540071830565919900754671875276898940293720792348512833794081816576.000
Uptime: 28  Threads: 2  Questions: 42  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 33  Threads: 1  Questions: 48  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 3332527319237083973768248584374409016814998216644938910673632465813980110450584796495745375459200638072133125049834907163746992858476814957895514748237326415554644625736158099803696210246886493546151783742917628334255202132895649724828426862693720260608.000
Uptime: 38  Threads: 1  Questions: 48  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 43  Threads: 2  Questions: 55  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -34076909069616747241397049775489428482532121380365237241076771436108041190461352333816941132060779703468962832762721141038498871689347072.000
Uptime: 48  Threads: 3  Questions: 86  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 53  Threads: 1  Questions: 95  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 58  Threads: 1  Questions: 102  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 62158761698541262452504308749255865204958097019616635700453439804540612615131964589606169299739552077069938607096299995774232985482390955304104559953280167129177460445828234343671174823417274832785062106243139033349706521034106885194741402566656.000
Uptime: 63  Threads: 1  Questions: 116  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 16646223275692247469415585885933614601053399871506826998685680125614862579102369304947977933829608061361304647074388225059293285223351346790400.000
Uptime: 68  Threads: 3  Questions: 135  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -2848394822916508672.000
Uptime: 73  Threads: 2  Questions: 158  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 27855619569407964849160187885854417888508053460642100413674101152754247521319604536772779072028672.000
Uptime: 78  Threads: 1  Questions: 186  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 83  Threads: 1  Questions: 186  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 38351644987906191930177989689986636069768307731263251350088804057050312184995185424689867603950151094407554869298821837718491744697973702374327379114621481156048027050139098561635552659390617811784379572707648863221251836529306491555077867818467267157426176.000
Uptime: 88  Threads: 1  Questions: 186  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 93  Threads: 1  Questions: 196  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 98  Threads: 1  Questions: 196  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 103  Threads: 1  Questions: 196  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 108  Threads: 1  Questions: 196  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 529394565120.000
Uptime: 113  Threads: 2  Questions: 205  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -4159842293301104522543455962161323597872394785856853166281171188255895246935162029021799282846957992683710635455961964449289014006922074364388113890001021067246128945003967283200.000
Uptime: 118  Threads: 1  Questions: 206  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -1860567826024616581206859961732263475091511847908387915857907346656766425214607561506285783628380445794222516362344755571098782928346585605728213724651101949526016.000
Uptime: 123  Threads: 1  Questions: 206  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 128  Threads: 1  Questions: 206  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 133  Threads: 1  Questions: 206  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 138  Threads: 1  Questions: 206  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 143  Threads: 1  Questions: 206  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 148  Threads: 1  Questions: 206  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 1840741718530295530868588833393780237691227208486565214572749396760291247626799153986954835903616621175529323540096939058174203121706330473791664586681288666658994425815354048130228279078737103555989419283114203231636816920576.000
Uptime: 153  Threads: 1  Questions: 206  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 158  Threads: 1  Questions: 212  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 163  Threads: 2  Questions: 221  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -2343520691696830449372917324333365568598712204890884522334808226325292669102815851314696911175844384146237066819814926956953540525816721562934253218896239090609614069554662378088617975369120561521344008292647466514361163448320.000
Uptime: 168  Threads: 2  Questions: 240  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 173  Threads: 3  Questions: 260  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 179  Threads: 1  Questions: 282  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 184  Threads: 1  Questions: 292  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 189  Threads: 1  Questions: 292  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 194  Threads: 2  Questions: 299  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.001
Uptime: 199  Threads: 1  Questions: 300  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -202423184441639449582066776334760760687167339741572265528895088528069294222487236003438814121942866176801505280.000
Uptime: 204  Threads: 1  Questions: 338  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 209  Threads: 1  Questions: 338  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 214  Threads: 1  Questions: 342  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 219  Threads: 1  Questions: 363  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 224  Threads: 1  Questions: 373  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 229379069164717620973045940488521336339038208.000
Uptime: 229  Threads: 1  Questions: 379  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 234  Threads: 1  Questions: 379  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 239  Threads: 1  Questions: 379  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 244  Threads: 1  Questions: 379  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -234210.625
Uptime: 249  Threads: 1  Questions: 379  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 186269986480412022333512947227569443828439049399659399567160755416592894938721550336.000
Uptime: 254  Threads: 1  Questions: 379  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 5140541615073637629041336886438216887612771752114454866357372300272779314061988794417528987398884464013997712117994212004837251312969845709541753085437211056903137092055110656613610872199285111342786315407133183054299131172596278085740873073185240015536108255974453735543146358079758451353151999301386240.000
Uptime: 5  Threads: 3  Questions: 50  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 10  Threads: 1  Questions: 58  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 15  Threads: 1  Questions: 70  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 20  Threads: 2  Questions: 105  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 25  Threads: 1  Questions: 118  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 30  Threads: 1  Questions: 118  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 3026686499541189282033828247018921918348002406199233965353736456429148847869934935658608265570882240551961393131019438738495045427540061943616497471103791417781942838031936074179483038137500934189296301984820608510268186435663087119074993467960804733688161776296787968.000
Uptime: 35  Threads: 1  Questions: 125  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 40  Threads: 2  Questions: 134  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -92559641157289381338776501546025278931271956773546886722224128.000
Uptime: 45  Threads: 3  Questions: 174  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -22899895302997449594626015631438496231846358735407829354916719937650922162056155041917272794646145500509924112110778243284433873429607477221625223119217105081045745617863222072412875553814556664692768338055065910247761087823872.000
Uptime: 50  Threads: 2  Questions: 215  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 55  Threads: 2  Questions: 245  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 277143787283596319728835825885930764330814752019186940358044961032111829457643837009522592176329788486085884813325537179301783796600627265536.000
Uptime: 60  Threads: 2  Questions: 272  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 65  Threads: 1  Questions: 279  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 70  Threads: 2  Questions: 286  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 926639939778802143515571278969746591989895884443412025194364326215744331592928619537644492424864512525992217317311303543290565331442115128943353229780028995719630859430519823879882351840828312826182045865940821792011151371496479873149243770757655268019787793914210157183029549522164853506048.000
Uptime: 5  Threads: 2  Questions: 20  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 10  Threads: 2  Questions: 63  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 15  Threads: 2  Questions: 100  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: -0.000
Uptime: 20  Threads: 1  Questions: 126  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
Uptime: 25  Threads: 1  Questions: 133  Slow queries: 0  Opens: 0  Flush tables: 0  Open tables: 1  Queries per second avg: 0.000
----------------------------------
And log is (again, about 2 restarting, related with above stats):

050413 08:20:49  mysqld started
050413  8:20:50  InnoDB: Started; log sequence number 0 43655
050413  8:20:50 [Note] Recovering after a crash using mysql-bin
050413  8:20:50 [Note] Starting crash recovery...
050413  8:20:50  InnoDB: Starting recovery for XA transactions...
050413  8:20:50  InnoDB: 0 transactions in prepared state after recovery
050413  8:20:50 [Note] Crash recovery finished.
050413  8:20:50  InnoDB: Starting recovery for XA transactions...
050413  8:20:50  InnoDB: 0 transactions in prepared state after recovery
050413  8:20:50 [Note] /usr/local/mysql/bin/mysqld: ready for connections.
Version: '5.0.3-beta-standard-log'  socket: '/tmp/mysql.sock'  port: 3306  MySQL Community Edition - Standard (GPL)
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=268435456
read_buffer_size=1044480
max_used_connections=4
max_connections=100
threads_connected=1
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 466543 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0x89f4600
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xbfe3f488, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
0x8097bf3
0x8338788
0x80a7bf9
0x38353739
New value of fp=0x37303835 failed sanity check, terminating stack trace!
Please read http://dev.mysql.com/doc/mysql/en/Using_stack_trace.html and follow instructions on how to resolve the stack trace. Resolved
stack trace is much more helpful in diagnosing the problem, so please do
resolve it
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at (nil)  is invalid pointer
thd->thread_id=5
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.

Number of processes running now: 0
050413 08:25:03  mysqld restarted
050413  8:25:03  InnoDB: Started; log sequence number 0 43655
050413  8:25:03 [Note] Recovering after a crash using mysql-bin
050413  8:25:03 [Note] Starting crash recovery...
050413  8:25:03  InnoDB: Starting recovery for XA transactions...
050413  8:25:03  InnoDB: 0 transactions in prepared state after recovery
050413  8:25:03 [Note] Crash recovery finished.
050413  8:25:03  InnoDB: Starting recovery for XA transactions...
050413  8:25:03  InnoDB: 0 transactions in prepared state after recovery
050413  8:25:03 [Note] /usr/local/mysql/bin/mysqld: ready for connections.
Version: '5.0.3-beta-standard-log'  socket: '/tmp/mysql.sock'  port: 3306  MySQL Community Edition - Standard (GPL)
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=268435456
read_buffer_size=1044480
max_used_connections=4
max_connections=100
threads_connected=2
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 466543 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0x89c4030
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xbfe1f488, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
0x8097bf3
0x8338788
0x80a7bf9
0x35383436
New value of fp=0x31323235 failed sanity check, terminating stack trace!
Please read http://dev.mysql.com/doc/mysql/en/Using_stack_trace.html and follow instructions on how to resolve the stack trace. Resolved
stack trace is much more helpful in diagnosing the problem, so please do
resolve it
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at (nil)  is invalid pointer
thd->thread_id=6
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.

Number of processes running now: 0
050413 08:26:13  mysqld restarted
050413  8:26:13  InnoDB: Started; log sequence number 0 43655
050413  8:26:13 [Note] Recovering after a crash using mysql-bin
050413  8:26:13 [Note] Starting crash recovery...
050413  8:26:13  InnoDB: Starting recovery for XA transactions...
050413  8:26:13  InnoDB: 0 transactions in prepared state after recovery
050413  8:26:13 [Note] Crash recovery finished.
050413  8:26:13  InnoDB: Starting recovery for XA transactions...
050413  8:26:13  InnoDB: 0 transactions in prepared state after recovery
050413  8:26:13 [Note] /usr/local/mysql/bin/mysqld: ready for connections.
Version: '5.0.3-beta-standard-log'  socket: '/tmp/mysql.sock'  port: 3306  MySQL Community Edition - Standard (GPL)
----------------------------------
Also, some aditional system info:
Linux version 2.4.21-27.0.2.EL (bhcompile@tweety.build.redhat.com) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-47)); Processor: Intel(R) Celeron(R) CPU 2.40GHz; 
Result of top command:
total   13.9%    0.0%    0.7%   0.0%     0.0%    0.0%   85.2%
Mem:  1026988k av,  993168k used,   33820k free,       0k shrd,   75780k buff 254044k actv,  502616k in_d,   18792k in_c
Swap: 2040244k av,   19544k used, 2020700k free                  604200k cached

PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU COMMAND
14527 mysql     16   0 63420  61M  2628 S    13.5  6.1   0:02   0 mysqld
14385 nobody    15   0  8568 6060  2380 S     0.5  0.5   0:00   0 httpd
(...)
----------------------------------
Bellow is queries by application used currently, just for your information. Again, I got the bug without any databases and table created (sure, except databases created default by MySQL), so in missing of any application, just watching mysqladmin on an empty server as data and queries.

SELECT STRID ,ROOTID ,LEVEL ,STREH ,title FROM categories WHERE LEVEL='1' OR LEVEL='2' ORDER BY ROOTID,STRID, LEVEL

SELECT keyword FROM kws WHERE position>50000 ORDER BY RAND() LIMIT 0,1000

SELECT keyword FROM kws WHERE position<50000 ORDER BY RAND() LIMIT 0,50

on tables structures:

CREATE TABLE categories (
  STRID mediumint(6) unsigned NOT NULL auto_increment,
  ROOTID enum('2','3','5','6','7','9','10','11','12','13','14','15') NOT NULL default '2',
  l mediumint(6) unsigned NOT NULL,
  r mediumint(6) unsigned NOT NULL,
  STREH smallint(3) unsigned NOT NULL,
  `LEVEL` enum('1','2','3','4','5','6','7','8','9','10','11','12') NOT NULL default '1',
  title varchar(84) NOT NULL,
  PRIMARY KEY  (STRID),
  KEY ROOTID (ROOTID),
  KEY STREH (STREH),
  KEY l (l),
  KEY r (r),
  KEY SRLR (STRID,ROOTID,l,r),
  KEY `LEVEL` (`LEVEL`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=404287 ;

CREATE TABLE kws (
  KID mediumint(6) unsigned NOT NULL auto_increment,
  keyword varchar(63) NOT NULL,
  position int(10) unsigned NOT NULL,
  PRIMARY KEY  (KID),
  KEY keyword (keyword(8)),
  KEY position (position)
) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=496841 ;

Both tables have about 25MB.
----------------------------------

Hope this info help you.

Thank you very much,
Iulian
[13 Apr 2005 14:33] Iulian Nastasache
I tested again without any application. 
Bug still exist and I can reproduce simple starting mysql, launching 
/usr/local/mysql/bin/mysqladmin -pk99Rw5My7j -i 5 -r status
and waiting a while (about 60 sec).
[13 Apr 2005 14:34] Iulian Nastasache
sorry for password above :) I think no password is reason.
[18 Apr 2005 13:52] Iulian Nastasache
That bug is not occured in 5.0.4-beta.
[18 May 2005 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[18 May 2005 23:41] Miguel Solorzano
Thank you for the feedback.