Bug #98224 Incorrect IS_DD_VERSION in 8.0.19
Submitted: 14 Jan 15:10 Modified: 15 Jan 9:23
Reporter: Zsolt Parragi (OCA) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Information schema Severity:S3 (Non-critical)
Version:8.0.19 OS:Any
Assigned to: CPU Architecture:Any

[14 Jan 15:10] Zsolt Parragi
Description:
In 8.0.19, the IS_DD_VERSION constant is set to 80020 (8.0.20): 

But it probably should be 80019 (8.0.19)

The root cause seem to be that two unrelated changes both increased it between 8.0.18 and 8.0.19:

https://github.com/mysql/mysql-server/commit/8745f8ccb5fb2aee8c21b43c9b8a6d7456a67a67#diff... (from 80018 -> 80019)
https://github.com/mysql/mysql-server/commit/48526e2da4f3eed8c055467a2311d23068a1b378 (from 80019 to 80020)

How to repeat:
Check the source at the linked line
[15 Jan 4:57] MySQL Verification Team
Hello Zsolt Parragi,

Thank you for the report and feedback.

regards,
Umesh
[15 Jan 9:23] Ståle Deraas
Closing as duplicate of bug#97948 (where a check has been implemented to prohibit such updates in the source code). Note that this version number is as such internal, and there are no consequences for users that the IS_DD_VERSION is 8.0.20 .