Bug #9806 Can't connect to MySQL server on 'localhost' (10055)
Submitted: 11 Apr 2005 8:49 Modified: 30 May 2013 12:39
Reporter: NOT_FOUND NOT_FOUND Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:mysql-4.0.21-win OS:Microsoft Windows (win 2000)
Assigned to: CPU Architecture:Any

[11 Apr 2005 8:49] NOT_FOUND NOT_FOUND
Description:
I have setup my server with following 

1. win 2000 server and IIS 
2. mysql-4.0.21-win 
3. myodbc-2.50.37-nt 
4. dbtools 3.23.32 

The program runs well for few days. I can insert, delete and edit data in database. couple of days later the system will have the following error. I have to reboot the server and the program works again! 

---------------------------------------------------------- 
Microsoft OLE DB Provider for ODBC Drivers error '80004005' 

[TCX][MyODBC]Can't connect to MySQL server on 'localhost' (10055) 

web_file_name.asp, line XXX 
---------------------------------------------------------- 

user rights, database and table's names have set right. MySQL service started. Just can't connect to database. even in the dbtools program and command prompt in user mode "root". 

No error shown at log file.

What is problem? How to solve it? I have post this bug a month before but no solution so far 

thks!

How to repeat:
don't know

Suggested fix:
reboot
[12 Apr 2005 3:32] Miguel Solorzano
Could you please upgrade the Connector/ODBC for the current one
3.51.11.

Thanks in advance.
[18 Apr 2005 3:36] NOT_FOUND NOT_FOUND
I installed the myodbc 3.51.11. but the same problem occurs.
[18 May 2005 9:49] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[1 Dec 2006 6:10] Mahayogya Tech Support
We are also facing the same problem, even after rebooting the server also, the problem is persisting.

Looking for a speedy reply guys,

thanks in advance
[11 Nov 2007 3:01] Mitch K
I too get the Can't connect to MySQL server on 'localhost' (10055) [2003]

MySql 5.0
Windows 32 Bit
[19 Feb 2009 12:38] Willem van Eekelen
First look if your MySQL service is running. Connections are often lost by using the scheduled backup with a wrong username/password.
[9 Feb 2010 5:06] Dave Dran
Maybe this will help. I had the same problem. I'm a windows guy but I'm sure the solution is similar in other systems. Go to "Program Files\MySQL\MySQLServer5.1\MySQL Server Instance Config Wizard." Select "Reconfigure Instance" then "Detailed Configuration." Walk through the wizard taking the defaults on everything or whatever you had before except select "Enable TCP/IP Networking". I disabled this during the install thinking that this would stop external connections and only allow localhost. Apparently not. I enabled this, restarted the service and it connected no problem after that. If anyone knows more about this parameter, please explain.

Hope this helps
[30 May 2013 12:39] Bogdan Degtyariov
Thank you for your bug report. This issue has already been fixed in the release version of that product, which you can download at

  http://www.mysql.com/downloads/