Bug #98034 Column comment is not saved
Submitted: 19 Dec 2019 19:07 Modified: 30 Dec 2019 6:00
Reporter: Karsten Wutzke Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:8.0.18 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:Any
Tags: workbench column comment

[19 Dec 2019 19:07] Karsten Wutzke
Description:
When modeling/entering a comment for a column, the value is not saved on Ctrl + S and/or the menu item.

How to repeat:
* pick any model you have available (or create a new one with a table)
* double-click any table
* single-click on any column
* change column comment in the multi-line comment box below
* press Ctrl + S or use the menu item to save
* close MySQL WB via top right X (without clicking anywhere into the model, exit immediately after comment change)
* reopen model
* visit the column

-> comment not changed!

Then, another strange thing is happening: as soon as you highlight any table's column after reopen, the model's * change indicator appears in the top left corner of the app.

STRANGE!

Suggested fix:
The comment must be stored.

The * indicator must not happen. (optional)
[19 Dec 2019 20:09] Karsten Wutzke
Workaround to achieve saving:

Click outside the currently highlighted table, then Ctrl + S or menu.
[20 Dec 2019 6:13] MySQL Verification Team
Hello Karsten Wutzke,

Thank you for the report.
I tried to reproduce your issue on Windows 10 with workbench 8.0.18 and followed exact mentioned steps but I am not seeing any issues at my end. 

Regards,
Ashwini Patil
[20 Dec 2019 20:56] Karsten Wutzke
Sorry, I'm on Windows 10 and only tested it there.

Have you tried it on Windows?
[20 Dec 2019 21:13] Karsten Wutzke
Yuk. Not my day. Sorry.

Maybe you haven't gotten it 100% right. I for my part can reproduce this 100% of the time.

The important part is to enter the comment, leave the cursor blinking at the end of the text, hit Ctrl + S and then click the WB X in the top-right corner.
[20 Dec 2019 21:31] Karsten Wutzke
I have uploaded a small video here: https://www.dropbox.com/s/mptpr6qj1g0665r/MySQL%20Workbench%202019-12-20%2022-11-40.mp4
[24 Dec 2019 10:43] MySQL Verification Team
Hello Karsten Wutzke,

Thank you for taking time and writing back to us.
Kindly close the model after saving the comment instead of directly closing the workbench.

Regards,
Ashwini Patil
[24 Dec 2019 10:45] MySQL Verification Team
8.0.18 test results

Attachment: 98034_test_results.docx (application/vnd.openxmlformats-officedocument.wordprocessingml.document, text), 704.51 KiB.

[25 Dec 2019 13:37] Karsten Wutzke
So, you concurr this is a bug or not?

Closing the model is just a workaround but NOT A FIX.

Please change the status if you CAN repeat.
[26 Dec 2019 10:53] MySQL Verification Team
Hello Karsten Wutzke,

Thank you for your feedback.
IMHO this is expected behavior but still I would check with WB developer and get back to you.

Regards,
Ashwini Patil
[27 Dec 2019 10:48] Karsten Wutzke
Sorry, but I don't agree that this is expected behavior.

In the bottom left status bar, the software says "Model saved." Closing WB and reopening the model and not seeing the column comment makes it obvious the model has NOT been saved and hence must be a bug.
[30 Dec 2019 6:00] MySQL Verification Team
Hello Karsten Wutzke,

Thank you for the feedback.
Agree with the reporter.

Regards,
Ashwini Patil