Bug #977 make install error
Submitted: 1 Aug 2003 8:40 Modified: 7 Aug 2003 8:12
Reporter: Till Klampaeckel Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.0.16 OS:FreeBSD (FreeBSD 4.6-RELEASE)
Assigned to: CPU Architecture:Any

[1 Aug 2003 8:40] Till Klampaeckel
"make install" produced an error when it tried to create a libexec directory, saying the the directory exists and didn't proceed with the installation.

How to repeat:
At first I compiled MySQL 4.0.14 with the following switches:
./configure --without-isam --without-innodb --without-docs --without-bench --without-debug

Then I did:
make install
[1 Aug 2003 8:49] Till Klampaeckel
Error message:

/usr/local/bin/bash ../mkinstalldirs /usr/local/libexec
mkdir /usr/local/libexec
mkdir: /usr/local/libexec: File exists
*** Error code 1

Stop in /usr/src/mysql-4.0.14/sql.
*** Error code 1

Stop in /usr/src/mysql-4.0.14/sql.
*** Error code 1

Stop in /usr/src/mysql-4.0.14/sql.
*** Error code 1

Stop in /usr/src/mysql-4.0.14.
[5 Aug 2003 4:32] Indrek Siitan
I wasn't able to repeat this. Looking at the 'mkinstalldirs' source code
it shows that it tries to detect using -d if the given argument exists and
is a directory, and if not, tries to create it.

The only thing I can think of is that your /usr/local/libexec is a symlink
or something that is not recognized by the -d check, and hence leads
trying to create the directory.
[5 Aug 2003 5:45] Till Klampaeckel
ls -l /usr/local/libexec
-rwxr-x---  1 root  daemon  30888 May 11 17:59 /usr/local/libexec

Doesn't look like a symlink to me.

So I gather this is more a automake related problem, right?

I fixed my install when I ran configure and specified the prefix "/usr/local/mysql4".
[7 Aug 2003 8:12] Indrek Siitan
Yes, it doesn't look like a symlink. But it doesn't look like a directory
either, which is what it should be. Something must be wrong with
your FreeBSD installation.