Bug #97592 MTR tests failed for main.lowercase_view
Submitted: 12 Nov 7:34 Modified: 12 Nov 14:06
Reporter: jibin ge Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Tests Severity:S7 (Test Cases)
Version:8.0.18 OS:Any
Assigned to: CPU Architecture:Any

[12 Nov 7:34] jibin ge
Description:

./mtr main.lowercase_view

Logging: ./mtr  main.lowercase_view
MySQL Version 8.0.18
Checking supported features
Using 'all' suites
Collecting tests
Checking leftover processes
Removing old var directory
Creating var directory '/opt/test/mysql-8.0.18-linux-x86_64-minimal/mysql-test/var'
Installing system database
Using parallel: 1

==============================================================================
                  TEST NAME                       RESULT  TIME (ms) COMMENT
------------------------------------------------------------------------------
[100%] main.lowercase_view                       [ fail ]
        Test ended at 2019-11-12 15:30:22

MTR's internal check of the test case 'main.lowercase_view' failed.
This means that the test case does not preserve the state that existed
before the test case was executed.  Most likely the test case did not
do a proper clean-up. It could also be caused by the previous test run
by this thread, if the server wasn't restarted.
This is the diff of the states of the servers before and after the
test case was executed:
mysqltest: Results saved in '/opt/test/mysql-8.0.18-linux-x86_64-minimal/mysql-test/var/tmp/check-mysqld_1.result'.
mysqltest: Logging to '/opt/test/mysql-8.0.18-linux-x86_64-minimal/mysql-test/var/tmp/check-mysqld_1.log'.
mysqltest: Connecting to server localhost:13000 (socket /opt/test/mysql-8.0.18-linux-x86_64-minimal/mysql-test/var/tmp/mysqld.1.sock) as 'root', connection 'default', attempt 0 ...
mysqltest: ... Connected.
mysqltest: Start processing test commands from './include/check-testcase.test' ...
mysqltest: ... Done processing test commands.
--- /opt/test/mysql-8.0.18-linux-x86_64-minimal/mysql-test/var/tmp/check-mysqld_1.result	2019-11-12 10:30:08.768559611 +0300
+++ /opt/test/mysql-8.0.18-linux-x86_64-minimal/mysql-test/var/tmp/check-mysqld_1.reject	2019-11-12 10:30:22.112684119 +0300
@@ -71,7 +71,10 @@
 #-------------- MYSQLTEST_VARDIR/run --------------
 mysqld.1.pid
 #-------------- MYSQLTEST_VARDIR/tmp --------------
+dd_bootstrap_test
 mysqld.1
+server.log
+tiny_bootstrap.sql
 #------------- MYSQLTEST_VARDIR/std_data ------------
 .mylogin.cnf
 14897.frm

mysqltest: Result content mismatch

not ok
safe_process[26706]: Child process: 26707, exit: 1

How to repeat:

./mtr main.lowercase_view
[12 Nov 11:36] Erlend Dahl
Thank you for the bug report. Verified as described.
[12 Nov 12:01] Erlend Dahl
Note that this points to an underlying bug in MTR:

Bug#97596 MTR doesn't check for remaining files when --parallel > 1

(which is the reason why this isn't seen in our internal testing).
[12 Nov 14:06] Paul Dubois
Posted by developer:
 
Fixed in 8.0.19.

Work was done for test suite. No changelog entry required.