Bug #97507 MySQL-8.0 upgrade is not showing lower version release series number in the log
Submitted: 6 Nov 2019 10:39 Modified: 12 Nov 2019 9:01
Reporter: Ramesh Sivaraman (OCA) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Logging Severity:S3 (Non-critical)
Version:8.0.18, 8.0.16, 8.0.17 OS:Any
Assigned to: CPU Architecture:Any

[6 Nov 2019 10:39] Ramesh Sivaraman
Description:
MySQL-8.0 upgrade is not showing lower version release series number in the error log.

Upgraded from 5.7.28 to 8.0.18

Error log

2019-11-06T10:21:32.277902Z 0 [Note] /ssd/ramesh/mysql57/bin/mysqld: Shutdown complete

2019-11-06T10:22:41.908934Z 0 [System] [MY-010116] [Server] /ssd/ramesh/mysql80/bin/mysqld (mysqld 8.0.18) starting as process 538
2019-11-06T10:22:41.922520Z 1 [System] [MY-011012] [Server] Starting upgrade of data directory.
2019-11-06T10:22:47.199735Z 2 [System] [MY-011003] [Server] Finished populating Data Dictionary tables with data.
2019-11-06T10:22:48.484604Z 5 [System] [MY-013381] [Server] Server upgrade from '50700' to '80018' started.
2019-11-06T10:22:58.383645Z 5 [System] [MY-013381] [Server] Server upgrade from '50700' to '80018' completed.
2019-11-06T10:22:58.458636Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2019-11-06T10:22:58.476524Z 0 [System] [MY-010931] [Server] /ssd/ramesh/mysql80/bin/mysqld: ready for connections. Version: '8.0.18'  socket: '/ssd/ramesh/mysql57/socket.sock'  port: 10196  MySQL Community Server - GPL.

How to repeat:
Upgrade MySQL server from 5.7.x to 8.0.18 and check the error log.
[6 Nov 2019 11:15] Umesh Shastry
Hello Ramesh,

Thank you for the report.
Imho this is not new in 8.0.18 but seen since 8.0.16.

regards,
Umesh
[12 Nov 2019 9:01] Ståle Deraas
The upgrade process does not know on 5.7 which micro-number it is upgrading from.
Since 8.0.16 the actions from the mysql_upgrade client was moved to the
mysqld proper, and we started to print these messages to the error log.