Bug #97470 MySQL Connector Net 8.0.16 Setup Wizard ended prematurely.
Submitted: 4 Nov 2019 13:25 Modified: 4 Nov 2019 14:02
Reporter: Sanidhya Verma Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:8.0.16 OS:Windows (Hp da-016282)
Assigned to: CPU Architecture:x86 (64 bit 4GB Ram 1TB Storage)

[4 Nov 2019 13:25] Sanidhya Verma
Description:
I have Recently Found a Error in My PC.
While Uninstalling MySQL Connector Net, It gives an Error:

MySQL Connector Net Setup Wizard ended prematurely.

MySQL Connector Net 8.0.16 Setup Wizard ended prematurely because of an error. Your System has not been modified. To install this program at a later time, run Setup Wizard Again. Click the Finish button to exit the Setup Wizard.

How i Can Solve this error. Please Tell Me ASAP...

How to repeat:
It might get Repeat when all the Folder and Hidden Folders are Uninstalled and All extra Apps for Developer Options Deleted leaving MySQL Net Connector

Suggested fix:
( No Suggestion. Not Confirmed. )
[4 Nov 2019 13:27] Sanidhya Verma
File Relating error.

Attachment: Screenshot_2.png (image/png, text), 149.33 KiB.

[4 Nov 2019 14:02] MySQL Verification Team
Thank you for the bug report. Version 8.0.16 is older please try version 8.0.18:

1: Action 10:56:49: INSTALL. 
1: 1: MySQL Connector Net 8.0.18 2: {6A8D895A-E2D0-4701-BE5D-478BEAC048D3} 
<CUT>
C:\Program Files (x86)\MySQL\Connector NET 8.0\
1: Key: \SOFTWARE\Microsoft\.NETFramework\v4.5.50709\AssemblyFoldersEx\MySQL Connector Net 8.0.18 v4.5.1, Name: , Value: C:\Program Files (x86)\MySQL\Connector NET 8.0\Assemblies\v4.5.2\
1: Key: \SOFTWARE\Microsoft\.NETFramework\v4.5.50709\AssemblyFoldersEx\MySQL Connector Net 8.0.18 v4.5.1, Name: , Value: 
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Linkage, Name: Export, Value: .NET Data Provider for MySQL
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Library, Value: netfxperf.dll
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Open, Value: OpenPerformanceData
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Collect, Value: CollectPerformanceData
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Close, Value: ClosePerformanceData
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: IsMultiInstance, Value: #0
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Counter Names, Value: 
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Counter Types, Value: 
1: Action 10:56:55: RollbackRegisterPerfCounterData. 
1: Action 10:56:55: RegisterPerfCounterData. 
1: Action 10:56:55: RegisterProduct. Registering product
1: {6A8D895A-E2D0-4701-BE5D-478BEAC048D3}
1: Action 10:56:55: MsiPublishAssemblies. Publishing assembly information
1: Application Context:Global, Assembly Name:MySql.Data,version="8.0.18.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:Google.Protobuf,version="3.6.1.0",culture="neutral",publicKeyToken="A7D26565BAC4D604",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:BouncyCastle.Crypto,version="1.8.3.0",culture="neutral",publicKeyToken="0E99375E54769942"
1: Application Context:Global, Assembly Name:Renci.SshNet,version="2016.1.0.0",culture="neutral",publicKeyToken="1CEE9F8BDE3DB106",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:SshNet.Security.Cryptography,version="1.2.0.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:MySql.Web,version="8.0.18.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Action 10:56:55: PublishFeatures. Publishing Product Features
1: Feature: EntityFramework
1: Feature: Core.Feature
1: Feature: WebProviders
1: Feature: Plugins
1: Action 10:56:55: PublishProduct. Publishing product information
1: Action 10:56:55: RollbackCleanup. Removing backup files
1: 1: MySQL Connector Net 8.0.18 2: {6A8D895A-E2D0-4701-BE5D-478BEAC048D3} 3: 1 
1: The action 'Install' for product 'Connector/NET 8.0.18' completed successfully.
[5 Nov 2019 14:42] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=97023 marked as duplicate of this one.
[12 May 11:31] MySQL Verification Team
Bug #107265 marked as duplicate of this one.