Bug #97465 java.lang.ArrayIndexOutOfBoundsException ServerPreparedStatement.java:441
Submitted: 4 Nov 2019 9:33 Modified: 4 Nov 2019 13:12
Reporter: zhongxuchen chen Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.0.18 OS:Any
Assigned to: CPU Architecture:Any

[4 Nov 2019 9:33] zhongxuchen chen
Description:
jdbc url:useServerPrepStmts=true;cachePrepStmts=true;prepStmtCacheSize=250;prepStmtCacheSqlLimit=2048

2019-11-04 16:30:23 [http-nio-8080-exec-1][org.sagacity.sqltoy.utils.SqlUtil][447] ==> java.lang.ArrayIndexOutOfBoundsException
java.sql.SQLException: java.lang.ArrayIndexOutOfBoundsException
        at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:129) ~[mysql-connector-java-8.0.17.jar:8.0.17]
        at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:97) ~[mysql-connector-java-8.0.17.jar:8.0.17]
        at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:89) ~[mysql-connector-java-8.0.17.jar:8.0.17]
        at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:63) ~[mysql-connector-java-8.0.17.jar:8.0.17]
        at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:73) ~[mysql-connector-java-8.0.17.jar:8.0.17]
        at com.mysql.cj.jdbc.ServerPreparedStatement.executeInternal(ServerPreparedStatement.java:441) ~[mysql-connector-java-8.0.17.jar:8.0.17]
        at com.mysql.cj.jdbc.ClientPreparedStatement.executeQuery(ClientPreparedStatement.java:1003) ~[mysql-connector-java-8.0.17.jar:8.0.17]

This error is randomness,It happens every few days!
Please don't think it's preparedstatement.setObject(index,xxx) index set error!
This must be a very deep bug hidden inside MySQL!
Please be seriously concerned!
Make people seriously doubt the reliability of MySQL!

How to repeat:
This error is randomness,It happens every few days!
此bug是隔一段时间必然出现,出现后再次执行又正常了,是无法重新的bug,非常无奈!
请不要简单的以为是开发者设置参数的低级bug,一定是mysql内部的bug!之前我们已经提报了with as (CTE)的bug并得到了修复。
[4 Nov 2019 13:12] Miguel Solorzano
Duplicate of: https://bugs.mysql.com/bug.php?id=97455.