Bug #97453 MTR tests failed for main.mysqladmin
Submitted: 1 Nov 7:37 Modified: 11 Nov 13:58
Reporter: jibin ge Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Tests Severity:S7 (Test Cases)
Version:8.0.18, 8.0.17, 8.0.16 OS:Any
Assigned to: CPU Architecture:Any
Tags: regression

[1 Nov 7:37] jibin ge
Description:
./mysql-test-run main.mysqladmin
Logging: ./mysql-test-run  main.mysqladmin
MySQL Version 8.0.18
Checking supported features
 - Binaries are debug compiled
Using 'all' suites
Collecting tests
Checking leftover processes
Removing old var directory
Creating var directory '/opt/test/simple/usr/local/mysql/mysql-test/var'
Installing system database
Using parallel: 1

==============================================================================
                  TEST NAME                       RESULT  TIME (ms) COMMENT
------------------------------------------------------------------------------
[100%] main.mysqladmin                           [ fail ]
        Test ended at 2019-11-01 12:01:18

MTR's internal check of the test case 'main.mysqladmin' failed.
This means that the test case does not preserve the state that existed
before the test case was executed.  Most likely the test case did not
do a proper clean-up. It could also be caused by the previous test run
by this thread, if the server wasn't restarted.
This is the diff of the states of the servers before and after the
test case was executed:
mysqltest: Results saved in '/opt/test/simple/usr/local/mysql/mysql-test/var/tmp/check-mysqld_1.result'.
mysqltest: Logging to '/opt/test/simple/usr/local/mysql/mysql-test/var/tmp/check-mysqld_1.log'.
mysqltest: Connecting to server localhost:13000 (socket /opt/test/simple/usr/local/mysql/mysql-test/var/tmp/mysqld.1.sock) as 'root', connection 'default', attempt 0 ...
mysqltest: ... Connected.
mysqltest: Start processing test commands from './include/check-testcase.test' ...
mysqltest: ... Done processing test commands.
--- /opt/test/simple/usr/local/mysql/mysql-test/var/tmp/check-mysqld_1.result	2019-11-01 07:01:15.241743667 +0300
+++ /opt/test/simple/usr/local/mysql/mysql-test/var/tmp/check-mysqld_1.reject	2019-11-01 07:01:18.005978593 +0300
@@ -71,6 +71,7 @@
 #-------------- MYSQLTEST_VARDIR/run --------------
 mysqld.1.pid
 #-------------- MYSQLTEST_VARDIR/tmp --------------
+.mylogin.cnf
 mysqld.1
 #------------- MYSQLTEST_VARDIR/std_data ------------
 .mylogin.cnf

mysqltest: Result content mismatch

not ok
safe_process[2497]: Child process: 2498, exit: 1

How to repeat:
./mysql-test-run main.mysqladmin
[4 Nov 5:16] Umesh Shastry
Hello jibin ge,

Thank you for the report and feedback.
Verified as described with 8.0.18 Generic Linux(binary tarball build).

regards,
Umesh
[5 Nov 7:30] jibin ge
Hi Umesh Shastry,

"verified" means you can repeat it or not? And if it is an issue, i can get the fix from which branch or version.
[11 Nov 13:58] Paul Dubois
Fixed in 8.0.19.

Work was done for test suite. No changelog entry required.