Bug #97334 dirpath Not Properly Initialized in class WinRemoteStats in wba_monitor_be.py
Submitted: 22 Oct 2019 18:06 Modified: 28 Oct 2019 7:15
Reporter: Brian White Email Updates:
Status: Won't Fix Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:8.0.18 CE OS:Any
Assigned to: CPU Architecture:Any
Tags: wba_monitor_be.py WinRemoteStats self.ssh dirpath

[22 Oct 2019 18:06] Brian White
Description:
Line 204 in is wrong on 2 accounts.
1. Its indented one too many times and will never be executed.
2. It should actually be: self.ssh = self.ctrl_be.editor.sshConnection

As the code is now, self.ssh will never get set and always be None.
Thus, dirpath will never be set and line 212 will result in an error.

This only occurs when connecting to a Windows instance of MySQL Server over SSH.

How to repeat:
Using MySQL Workbench, connct to a Windows instance of MySQL Server over SSH.
Select Server Status from the Navigator|administration tab.
Get error.

Suggested fix:
        if self.ctrl_be.server_profile.uses_ssh:
            if self.ctrl_be.editor.sshConnection.isConnected() == 0:
                if self.ctrl_be.editor.sshConnection.connect() != 0:
                    raise OperationCancelledError("Could not connect to SSH server")
            self.ssh = self.ctrl_be.editor.sshConnection

Note that "self.ssh = self.ctrl_be.editor.sshConnection" aligns with "if self.ctrl_be.editor.sshConnection.isConnected() == 0:"
[28 Oct 2019 7:15] MySQL Verification Team
Hello Brian White,

Thank you for the report and feedback.
Observed this on Win10 using WB 8.0.18 with tcp/ip over ssh connection to MySQL Server running on windows host(local in my case).

regards,
Umesh
[14 Sep 18:05] Omer Barnir
Posted by developer:

This issue applies to the legacy MySQL Workbench 8.x implementation that is no longer supported or maintained.
MySQL Workbench 26.7 is a complete rewrite using a new technology stack and does not use the affected legacy implementation.
Therefore, this issue is not applicable to the current MySQL Workbench product and as such is closed.