Bug #97298 Method 'get_Info' missing from MySql.Data.EntityFrameworkCore 8.0.18.0
Submitted: 20 Oct 2019 2:09 Modified: 21 Oct 2019 4:24
Reporter: Christian Benner Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:8.0.18.0 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[20 Oct 2019 2:09] Christian Benner
Description:
.Net Core 3.0 EntityFrameworkCore 3.0 get this exception:

System.TypeLoadException: Method 'get_Info' in type 'MySql.Data.EntityFrameworkCore.Infraestructure.MySQLOptionsExtension' from assembly 'MySql.Data.EntityFrameworkCore, Version=8.0.17.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d' does not have an implementation.

How to repeat:
- VS 2019, C/NET 8.0.18, Microsoft.EntityFrameworkCore 3.0.0
- MySql.Data.MySqlClient .Net Core Class Library - 8.0.18
- MySql.Data.EntityFrameworkCore for Entity Framework - 8.0.18
[20 Oct 2019 2:16] Christian Benner
I can't believe, that such an error is marked as "verified" in 8.0.17 but is rolled out in 8.0.18 again. Some bs is Happening with Visual Studio Integration 2.0.5m  - obviously only one developer is working on that stuff. In all other cases ist hard to explain what is going on with earlier good Tools and helpers… You should remember: Only with working Tools external developers will use the database and only then you'll sell it to their customers.

In my case: I've moved all new Projects to other Databases (and they're not from Oracle - sorry … but the "Oracle" Fails since a while...
[21 Oct 2019 3:23] Bradley Grainger
MySql.Data.EntityFrameworkCore supports (and is only compatible with) EF Core 2.1.

Using mismatched EF Core and DB provider libraries will result in errors similar to the one you reported.

If you need a MySQL EF Core provider that's compatible with EF Core 3.0, your only option right now is the 3.0.0-rc1 version of https://www.nuget.org/packages/Pomelo.EntityFrameworkCore.MySql (see the compatibility table at https://github.com/PomeloFoundation/Pomelo.EntityFrameworkCore.MySql#compatibility ).

Otherwise, if you want to stick with MySql.Data.EntityFrameworkCore you'll need to roll back to EF Core 2.1.
[21 Oct 2019 4:24] Umesh Shastry
Hello Christian Benner,

Thank you for the report and feedback.
Marking this as duplicate of Bug #96990, please see Bug #96990.

regards,
Umesh