Bug #97240 date value converts to UTC datetime in new mysql jdbc/jar driver
Submitted: 15 Oct 2019 20:06 Modified: 13 Feb 14:17
Reporter: Chris thomas Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / J Severity:S1 (Critical)
Version:8.0.18 OS:Any
Assigned to: CPU Architecture:Any
Tags: date query

[15 Oct 2019 20:06] Chris thomas
Description:
a query of the date field with the new MySQL (8.0.18 and 8.0.17) connect jar driver returns different dates from a column.   the MySql5 driver (5.1.35) returns the correct dates.  We are thinking it appears to converts to UTC time.  Mysql5 is the correct date

version 8: mysql-connector-java-8.0.18.jar
version 5:  mysql-connector-java-5.1.35-bin.jar

We run the same query (select * from vwEpicQuarter) using both drivers in Sql Workbench.

mysql5 column created date: 2019-10-15 14:40:22
mysql8 column created date: 2019-10-15 10:40:22   

How to repeat:
query a date/time column using both drivers and the time and (sometimes date) will be different.

Suggested fix:
remove UTC fomatting
[16 Oct 2019 10:08] Umesh Shastry
Hello Chris thomas,

Thank you for the report.

regards,
Umesh
[13 Feb 14:17] Alexander Soklakov
Hi Chris,

This is a duplicate of Bug#93444.