Bug #97201 Uninstalling MySQL on a Mac deletes the /usr/local directory
Submitted: 11 Oct 2019 12:12 Modified: 17 Feb 2021 14:27
Reporter: Rathin Bhargava Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:8.0.17 OS:MacOS (10.14.6)
Assigned to: CPU Architecture:Any

[11 Oct 2019 12:12] Rathin Bhargava
Description:
Uninstalling MySQL on a Mac deletes everything in the /usr/local directory. This only happens when we don't delete all the support files initially and then delete everything. I have reproduced this bug twice. 

How to repeat:
1. Install MySQL
2. Click 'unistall' via System Preferences -> MySQL
3. You're prompted to check a box "Also uninstall this preference pane and all launchd support files"
4. Do not click the box and click OK.
5. Click the uninstall button again, but this tie check the box. 
6. See that your /usr/local directory is now blank and 15+ GB of data is now missing

Suggested fix:
I have no idea
[16 Oct 2019 6:56] MySQL Verification Team
Hello Rathin,

Thank you for the report and feedback.

regards,
Umesh
[21 Oct 2019 9:39] MySQL Verification Team
Bug #96981 marked as duplicate of this one
[17 Feb 2021 14:27] Erlend Dahl
Fixed in 8.0.19.