Bug #97045 lower_case_file_system cannot be set in my.cnf
Submitted: 27 Sep 2:52 Modified: 27 Sep 2:59
Reporter: Federico Razzoli Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:8.0 OS:Any
Assigned to: CPU Architecture:Any

[27 Sep 2:52] Federico Razzoli
Description:
If I try to set lower_case_file_system in my.ini MySQL fails to start:

2019-09-27T02:43:00.053458Z 0 [ERROR] [MY-000067] [Server] unknown variable 'lower_case_file_system=1'.

But I can see the variables:

mysql> SELECT @@lower_case_file_system;
+--------------------------+
| @@lower_case_file_system |
+--------------------------+
|                        0 |
+--------------------------+
1 row in set (0.00 sec)

Also, the variable is still present in the documentation:
https://dev.mysql.com/doc/refman/8.0/en/server-system-variables.html#sysvar_lower_case_fil...

How to repeat:
See above
[27 Sep 2:56] Federico Razzoli
If I try to set lower_case_file_system in my.ini MySQL fails to start:

2019-09-27T02:43:00.053458Z 0 [ERROR] [MY-000067] [Server] unknown variable 'lower_case_file_system=1'.

But I can see the variables:

mysql> SELECT @@lower_case_file_system;
+--------------------------+
| @@lower_case_file_system |
+--------------------------+
|                        0 |
+--------------------------+
1 row in set (0.00 sec)

Also, the variable is still present in the documentation:
https://dev.mysql.com/doc/refman/8.0/en/server-system-variables.html#sysvar_lower_case_fil...
[27 Sep 2:59] Federico Razzoli
I've read the docs more carefully. The variable is read only, so this behaviour seems to be expected. I'm trying to close the bug myself as "not a bug", sorry for the noise.