Bug #96951 Could not load file or assembly
Submitted: 19 Sep 2019 21:55 Modified: 20 Sep 2019 4:53
Reporter: Alan Webster Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:8.0.17 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:x86 (Intel)
Tags: ADO.NET SSH

[19 Sep 2019 21:55] Alan Webster
Description:
I am creating a connection using the latest ADO.NET driver and using the SQL Management Studio data import wizard.  I am using the same credential as used in MySQL workbench which work correctly.  I have entered the details but upon testing the connection receive the following error message.

Could not load file or assembly 'Renci.SshNet, Version=2016.1.0.0, Culture=neutral, PublicKeyToken=1cee9f8bde3db106' or one of its dependencies. The system cannot find the file specified. (MySql.Data)

------------------------------
Program Location:

   at MySql.Data.MySqlClient.MySqlConnection.Open()
   at Microsoft.SqlServer.Dts.DtsWizard.DTSWizard.GetOpenedConnection(WizardInputs wizardInputs, String connEntryName)
   at Microsoft.SqlServer.Dts.DtsWizard.Step1.OnLeavePage(LeavePageEventArgs e)

How to repeat:
Use SQL Manangement studio and data import wizard.

I am also having the same error when using Jet Analytics (TimeXTender) and creating a connection.
[20 Sep 2019 4:53] Umesh Shastry
Hello Alan Webster,

Thank you for the report.
Imho this is duplicate of Bug #96614, please see Bug #96614.

Thank you for your interest in MySQL.

- Bug#96614

 [22 Aug 23:16] Christine Cole

Posted by developer:
 
Fixed as of the upcoming MySQL Connector/NET 8.0.18 release, and here's the changelog entry:

The Renci.SshNet.dll deployment was problematic for Connector/NET 8.0.17
MSI installations. Some applications, such as Microsoft Excel, were unable
to read MySQL data as a result. This fix removes unnecessary dependencies
on the DLL and also ensures that the MSI installation deploys the correct
Renci.SshNet.dll to the GAC.

Thank you for the bug report.

regards,
Umesh