Bug #96945 [ERROR] SSL error: Unable to get private key from 'server-key.pem'
Submitted: 19 Sep 2019 10:39 Modified: 19 Sep 2019 11:37
Reporter: Samson Lin Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Errors Severity:S3 (Non-critical)
Version:5.7.27 OS:Red Hat (Red Hat Enterprise Linux Server release 7.7 (Maipo))
Assigned to: CPU Architecture:x86 (3.10.0-1062.el7.x86_64)
Tags: SSL Error

[19 Sep 2019 10:39] Samson Lin
Description:
After installing MySQL v5.7.27 into RedHat Enterprise Linux v7.7, I went to /var/log/mysqld.log and discovered the following error messages:

...
2019-09-19T10:21:07.548693Z 0 [Note] Found ca.pem, server-cert.pem and server-key.pem in data directory. Trying to enable SSL support using them.
2019-09-19T10:21:07.555964Z 0 [ERROR] SSL error: Unable to get private key from 'server-key.pem'
2019-09-19T10:21:07.555983Z 0 [Warning] Failed to set up SSL because of the following SSL library error: Unable to get private key
...

I didn't do anything after installing MySQL.  Just reboot after MySQL installation.

I downloaded the following package from Oracle website (https://dev.mysql.com/downloads/mysql/5.7.html), mysql-5.7.27-1.el7.x86_64.rpm-bundle.tar.  I extracted all from the tar file and installed by rpm.  Here are my installed MySQL packages:

# rpm -qa|grep mysql
mysql-community-libs-5.7.27-1.el7.x86_64
mysql-community-embedded-compat-5.7.27-1.el7.x86_64
mysql-community-embedded-devel-5.7.27-1.el7.x86_64
mysql-community-server-5.7.27-1.el7.x86_64
mysql-community-test-5.7.27-1.el7.x86_64
mysql-community-common-5.7.27-1.el7.x86_64
mysql-community-devel-5.7.27-1.el7.x86_64
mysql-community-libs-compat-5.7.27-1.el7.x86_64
mysql-community-embedded-5.7.27-1.el7.x86_64
mysql-community-client-5.7.27-1.el7.x86_64

I did not generate any SSL certificates and I did not manipulate the /etc/my.cnf file.

How to repeat:
# systemctl restart mysqld
[19 Sep 2019 10:45] Samson Lin
MySQL log under /var/log

Attachment: mysqld.log (application/octet-stream, text), 18.88 KiB.

[19 Sep 2019 11:37] Umesh Shastry
Hello Samson Lin,

Thank you for the report and feedback.
Imho this is duplicate of Bug #71271, please see Bug #71271

regards,
Umesh