Bug #96793 Error Loading Schema after 8.0.16 and 8.0.17 upgrades
Submitted: 9 Sep 2019 13:06 Modified: 9 Sep 2019 13:56
Reporter: Kevin Finkenbinder Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.16 & 8.0.17 OS:Any (At Least Mac and Windows )
Assigned to: CPU Architecture:Any

[9 Sep 2019 13:06] Kevin Finkenbinder
Description:
Original Report (https://bugs.mysql.com/bug.php?id=95228)
====================
After upgrading MySQL Workbench 8.0.15 to 8.0.16 anytime I connect to a database, the following error shows up in the Output pane:

16:10:26	Error loading schema content	Error Code: 1142 SELECT command denied to user 'xxxxxxxxxxx' for table 'user_variables_by_thread'

In addition, each item in the schemas pane (Tables/Views/Stored Procedures/Functions) has  "could not be fetched" next to it.

Oddly enough, the tables and other items are actually listed and function normally.

Nothing else changed other than the Workbench upgrade.

=============================
Problem continues in 8.0.17

See also https://bugs.mysql.com/bug.php?id=95335

How to repeat:
Open MySQL Workbench and connect to a database as a non-root/non-admin user who does not explicitly have select rights on the performance schema.
[9 Sep 2019 13:09] Kevin Finkenbinder
See files at https://bugs.mysql.com/bug.php?id=95228&files=1
[9 Sep 2019 13:56] Miguel Solorzano
Duplicate of https://bugs.mysql.com/bug.php?id=95335. See developer comment:

 [9 Aug 7:33] Mike Lischke (modified)

The patch for this bug is here: https://github.com/mysql/mysql-workbench/commit/4e92d2d27e2e6a1ba8c0a3cf6bf96799bde8ecb8. It's a different bug number because we had found this problem internallly already a few days before it was reported here.

However, this is a twofold problem. One aspect is the version of the server where this table is supported. Another is that for user accounts that don't have the privilege to access the P_S, this will still fail. A fix for the latter problem has already been pushed and will be available with the next release of MySQL Workbench.