Bug #96782 Shutdown MySQL if the BP oversize the server memory
Submitted: 6 Sep 2019 17:50 Modified: 14 Oct 2019 13:08
Reporter: Vinicius Malvestio Grippa Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S4 (Feature request)
Version:Any OS:Any
Assigned to: CPU Architecture:Any

[6 Sep 2019 17:50] Vinicius Malvestio Grippa
Description:
Avoid MySQL to initialize with oversize memory exceed the hardware/VM resources.

It obviously is a fault of careless dbas, however, the consequences are terrible and awful.

How to repeat:
-

Suggested fix:
Throw an error and shutdown MySQL.
[14 Oct 2019 12:56] Sinisa Milivojevic
Hello Mr. Grippa,

You have not stated which MySQL version and release are you using. You also did not state the OS and its version that you are using.

You could let us know the size of buffer pool that you have set and the available virtual memory.
[14 Oct 2019 13:01] Vinicius Malvestio Grippa
Hi Sinisa,

Thanks for your reply. It is in any version. The error message should be simpler.

Example: If my server has 8Gb of RAM, my buffer pool can't be configured with 9GB. The idea is to avoid simple mistakes of adding an extra zero on the bytes for example.
[14 Oct 2019 13:04] Sinisa Milivojevic
Hi,

I do not think that your feature request is justified.

We can not protect users from making huge mistakes. Also, we can not change error messages during the GA stage of any MySQL version.

Not a bug.
[14 Oct 2019 13:08] Vinicius Malvestio Grippa
Hi,

It is a similar request as this:

https://bugs.mysql.com/bug.php?id=96207

I agree it is not a bug. I opened it as a feature request.

But I trust in Oracle judgment in deciding that this is not a feasible FR.

Thanks.
[14 Oct 2019 13:21] Przemyslaw Malkowski
"We can not protect users from making huge mistakes. "
Well, some actions are forbidden in MySQL exactly to protect users, aren't they? 
Also, why can't we at least inform about them? That is why warnings are for, no?

I agree that shutting down the server would be probably too aggressive solution, but IMHO a bold warning on startup output and in the error log, would be very nice to have. Every DBA can make this simple mistake and better if he/she knows it right after the restart, rather then when BP is starts to fill up and machine starts to swap heavily, leaving the system unresponsive...