Bug #96683 MySQL Server 8.0.17 Installation fails
Submitted: 28 Aug 15:47 Modified: 16 Nov 13:00
Reporter: Sreenivasa Sama Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:8.0.17 OS:Microsoft Windows (Windows 10)
Assigned to: CPU Architecture:Any
Tags: The action 'Install' for product 'MySQL Server 8.0.17' failed.

[28 Aug 15:47] Sreenivasa Sama
Description:

1: Key: \Console\MySQL 8.0 Command Line Client - Unicode, Name: , Value: 
1: Key: \Software\MySQL AB\MySQL Server 8.0, Name: installed, Value: #1
1: Action 21:07:34: ExecSecureObjects. 
1: Action 21:07:34: Rollback. Rolling back action:
1: ExecSecureObjects
1: Writing system registry values
1: Creating shortcuts
1: Copying new files
1: Creating folders
1: Updating component registration
1: 1: MySQL Server 8.0 2: {827F2F48-CCB9-4018-9AA3-0CA9FA3223E1} 3: 3 
1: The action 'Install' for product 'MySQL Server 8.0.17' failed.

How to repeat:
Tried all the things to include visual studio 2017 version as well. But nothing worked. Please suggest how to solve that, Looked earlier blogs, but no solution. 
There are many blogs with similar bug but not for this version. There is no solution found. Please help.
[28 Aug 15:48] Sreenivasa Sama
Log of error while installing MqSQL Server 8.0.17

Attachment: MqSQL bug.txt (text/plain), 22.37 KiB.

[28 Aug 16:44] Miguel Solorzano
Thank you for the bug report. I couldn't repeat on Windows 10 Pro 64-bits, please describe the full install process step by step which failed for you. Thanks.
[28 Aug 21:49] Sreenivasa Sama
I have used MYSQL Installer to do the installation, I have selected MYSQL Server and followed to next step. It installed everything and was looking OK , but it failed. I am attaching screenshots of my installation process. Please check and help.
[28 Aug 21:50] Sreenivasa Sama
MySQL Server installation failure screenshots

Attachment: MySQL Server installation error screenshots.docx (application/vnd.openxmlformats-officedocument.wordprocessingml.document, text), 864.21 KiB.

[16 Oct 13:00] Miguel Solorzano
Please try version 8.0.18. Thanks.
[17 Nov 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".