Bug #96545 power BI cannot connect to mysql
Submitted: 15 Aug 2019 4:43 Modified: 22 Aug 2019 10:47
Reporter: shawn gao Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:8.0.17(community) OS:Microsoft Windows (64-bit OS)
Assigned to: CPU Architecture:Any

[15 Aug 2019 4:43] shawn gao
Description:
when I tried to connect to MySQL(localhost:3306) from power BI, some issues happened as below:

Details: "error reading data from provider:" failed to load file or assembly "Renci.SshNet, Version=2016.1.0.0, Culture=neutral, PublicKeyToken=1cee9f8bde3db106" or one of its dependencies.Specified. The system cannot find The file specified."

MySQL version: 8.0.17(community)
power BI: office365_2016

How to repeat:
every times.
[17 Aug 2019 14:58] Carlos Romero Hombrebueno
Hello, I had the same error and the solution was to use the old version 6.10.7
Carlos
[17 Aug 2019 15:02] Carlos Romero Hombrebueno
I mean the connector's version/NET . I hope it works for you

https://downloads.mysql.com/archives/c-net/
[18 Aug 2019 4:49] shawn gao
hi, Carlos Romero, thanks for your help very much, It works now.
[19 Aug 2019 13:47] W. Eicher
I suppose it depends on the different PublicKeyTokens:
mysql.data searches for Renci.SshNet with PublicKeyToken = 1cee9f8bde3db106 but the entry in the gac is PublicKeyToken = c5687fc88969c44d
[22 Aug 2019 10:47] MySQL Verification Team
Hello shawn gao,

Thank you for the report.
Marking this as duplicate of Bug #96614, please see Bug #96614.
Agree, this should have been the base bug but since I verified Bug #96614 before this and hence marking this as duplicate for now.  Even if you feel that your issue is somewhat different i.e PowerBI vs Excel, the resolution is likely to be the same. 

Thank you for your interest in MySQL.

regards,
Umesh