Bug #96505 MySQL Workbench 8.0.17 fails to install on MacOS 10.13 High Sierra
Submitted: 12 Aug 2019 7:27 Modified: 7 Jan 2020 0:45
Reporter: GreenCollar IT Manager Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.17 OS:MacOS
Assigned to: CPU Architecture:x86
Tags: High Sierra, macos, mojave, workbench

[12 Aug 2019 7:27] GreenCollar IT Manager
Description:
On the MySQL Workbench downloads page, it states: "Packages for Mojave (10.14) are compatible with High Sierra (10.13)”. However, the latest version of Workbench, does not install successfully on Mac OS High Sierra with the system reporting that MacOS 10.14 Mojave is required to run it.

How to repeat:
Install MySQLWorkbench 8.0.17 on MacOS High Sierra 10.13.
[12 Aug 2019 8:22] MySQL Verification Team
Thank you for the bug report. Could you please provide a screenshot of the error message. Thanks.
[12 Aug 2019 8:49] GreenCollar IT Manager
Screenshot of error message when running Workbench 8.0.17 on MacOS 10.13

Attachment: Screenshot 2019-08-12 18.47.15.png (image/png, text), 146.96 KiB.

[12 Aug 2019 10:45] MySQL Verification Team
Hello!

Thank you for the  bug report.
We've checked internally and confirmed from WB(Marcin S) Developer that we are longer supporting < macOS 10.14 versions and same can be confirmed from the "Supported Platforms: MySQL Workbench" i.e https://www.mysql.com/support/supportedplatforms/workbench.html
Verifying this bug report so that incorrect information present in the download page is corrected/removed i.e "Packages for Mojave (10.14) are compatible with High Sierra (10.13)".

regards,
Umesh
[12 Aug 2019 10:57] Mike Lischke
As an additional note: MySQL Workbench only supports the latest OS versions for macOS (and Windows + Windows Server), however there's a transition period of a few months after a new release of macOS came out, where it still supports the previous OS version.

Users that must stay with an older macOS version can only use an older MySQL Workbench release.
[12 Aug 2019 12:47] GreenCollar IT Manager
[12 Aug 10:57] Mike Lischke wrote:
...
>Users that must stay with an older macOS version can only use an older
>MySQL Workbench release.

What - so, in this case High Sierra users must go from 8.0.16 back to 6.3.10?  Isn’t that a bit drastic? How about warning us of the cut-off for previous version support so we can at least keep as much feature parity with the latest version as possible by not upgrading?
[13 Aug 2019 7:27] Mike Lischke
Did you upgrade from 6.3.10 actually or why do you mention that here? As I wrote in my comment above, a specific MySQL Workbench version only supports the latest macOS version (of that time of its release, of course, plus some transition period). That obviously means you should pick a version that came out around the release of macOS 10.14 (or shortly after) to still get support for 10.13. That would include 8.0.16, 8.0.15 and 8.0.14 (the last one being released close to the macOS 10.14 release date).
[13 Aug 2019 8:18] GreenCollar IT Manager
13 Aug 7:27] Mike Lischke wrote:

“...That obviously means you should
pick a version that came out around the release of macOS 10.14 (or
shortly after) to still get support for 10.13”

Well yes - I’d like to be able to do that, but can’t see how to do that now. Those earlier versions (8.0.14-16) don’t seem to be available - only the last earlier release; i.e. 6.3.10.
[13 Aug 2019 8:37] Simon Vacker
You can find older versions of WB in the archives https://downloads.mysql.com/archives/workbench/
[13 Aug 2019 23:09] GreenCollar IT Manager
[13 Aug 8:37] Simon Vacker wrote:

>You can find older versions of WB in the archives
>https://downloads.mysql.com/archives/workbench/

Ok - thanks for that Simon.
[29 Aug 2019 21:15] Christine Cole
Posted by developer:
 
Out-of-date content was removed from https://dev.mysql.com/downloads/workbench/ 
and the platform policy was restated in documentation with a link to 
https://www.mysql.com/support/supportedplatforms/workbench.html added.
[19 Sep 2019 19:01] Mark Twain
You can still run the Workbench 8.0.16, downloads are available on the net. I just restored mine WB from a TM backup (After reinstalling the macos 10.13 and finding out that WB 8.0.17 won't run).
[31 Dec 2019 15:24] Courtney Hall
FWIW, in Info.plist the LSMinimumSystemVersion is 10.11.0, which is El Capitan, so if the application truly doesn't support earlier OS versions, that's at least one bug.  

That said, unless WB now implements Dark Mode (without fallback), I can't think of any reason why the latest version wouldn't run on MacOS versions >= 10.11, as of 8.0.18.
[7 Jan 2020 0:45] GreenCollar IT Manager
This bug may be closed, but the MySQLWorkbench download page still erroneously claims that "Packages for Mojave (10.14) are compatible with High Sierra (10.13)” on the latest version (8.0.18). It has been established that is NOT the case since v 8.0.17. Fix please.
[20 Mar 2020 10:47] s fsssss
My Mac OS'versin is High Sierra (10.13) too.

And I also noticed that "Packages for Mojave (10.14) are compatible with High Sierra (10.13)” on https://downloads.mysql.com/archives/workbench/.

So, I download the 8.0.18 version.

And finally I came here.
Thank you all the same!
[10 Nov 2020 23:19] Frederick Evans
There is a well known bug in MySQL workbench, v.8.22 and all versions. The application will not run on MAC catalina. there is no solution nor work around