Bug #9650 System crash when user checks server status continously (>35 times))
Submitted: 5 Apr 2005 14:49 Modified: 5 Apr 2005 15:02
Reporter: Disha Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0.3 Beta OS:Microsoft Windows (Windows 2003)
Assigned to: CPU Architecture:Any

[5 Apr 2005 14:49] Disha
Description:
Command \s gets status information from the server. Executing it continously crashes the server. We have a consistent repro when we executed it 30 times.

How to repeat:
1) Execute \s 30-40 times.
2) After that execute any sql statement, like Select * from t1.

ACTUAL RESULT
ERROR 2006 (HY000): MySQL server has gone away
No connection. Trying to reconnect...
ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)
ERROR:
Can't connect to the server

EXPECTED RESULT
Server should not crash.
[5 Apr 2005 14:58] Hartmut Holzgraefe
Duplicate of 9646 that happened to be reported just a few minutes earlier
[5 Apr 2005 15:02] MySQL Verification Team
I wasn't able to repeat on Windows/Linux BK server 5.0.4:

hreads: 1  Questions: 87  Slow queries: 0  Opens: 0  Flush tables: 1  Open tables: 0  Queries per second avg: 1.279  Mem
ry in use: 8390K  Max memory used: 8409K
-------------

ysql> select version();
------------------+
 version()        |
------------------+
 5.0.4-beta-debug |
------------------+
 row in set (0.00 sec)