Bug #96274 Unable to disable stopwords as a "USER" on a shared server
Submitted: 22 Jul 2019 20:30 Modified: 29 Jul 2019 13:50
Reporter: George Sutherland Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S4 (Feature request)
Version:5.6 OS:Any
Assigned to: CPU Architecture:Any
Tags: InnoDB ft_user_stopword_table

[22 Jul 2019 20:30] George Sutherland
Description:
Hi, I am a typical webhosting customer, with a cPanel account on a shared server at Hostgator.com. Is there a way to either (A) disable stopwords, or (B) set a custom stopword table, as a "USER" on a shared cPanel server (MySQL v5.6)... All of the instructions refer to "SET GLOBAL ft_server_stopword_file" which I can't do. And any attempt to do it via "SESSION ft_user_stopword_file" ends as soon as the Session ends.

I see instructions for putting ft_stopword_file="" in the user-level ~/.my.cnf file... however, every variation of this I have tried has no effect on my search. My tables are InnoDB, and I recreate the fulltext indexes after each experiment, but with no actual affect.

How to repeat:
Just try to turn off, or customize, stopwords as a "user" on a shared server - without admin permissions.

Suggested fix:
Is there a simply way to accomplish this as the actual CUSTOMER who pays for hosting... I know the hosting company is your customer, but I'm paying the bill! Any instructions would be appreciated!
[29 Jul 2019 13:50] Sinisa Milivojevic
Hi Mr. Sutherland,

Thank you for your bug report.

However, this is not a bug. There is a fully explained procedure for what you are trying to accomplish in 5.6.

You can find it described here:

https://dev.mysql.com/doc/refman/5.6/en/innodb-information-schema-fulltext_index-tables.ht...