Bug #96228 MySQL 8.0.16 EntityFramework Core connector bug with query expression evaluation
Submitted: 17 Jul 7:03 Modified: 17 Jul 7:34
Reporter: Kok How Teh Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:8,0.16 OS:Ubuntu
Assigned to: CPU Architecture:x86
Tags: connector, dotnet, entityframework, MySQL

[17 Jul 7:03] Kok How Teh
Description:
I am using EntityFramework Core 2.2 with your MySql.Data.EntityFrameworkCore 8.0.16. Using expression evaluations at the server throws strange exception:

System.InvalidOperationException: No coercion operator is defined between types 'System.Int16' and 'System.Boolean'.

How to repeat:
Use query that includes c# language expression evaluation!
[17 Jul 7:15] Kok How Teh
For example:

dbcontext.DbSet.Where(x => x.Name.ToLower())

dbContext.DbSet.Where(x => x.Timestamp == DateTimeOffset.UtcNow)
[17 Jul 7:34] Umesh Shastry
Hello Kok How Teh,

Thank you for the report.
Imho this is duplicate of Bug #92987, please see Bug #92987

regards,
Umesh