Bug #96159 MYSQL 5.7 being installed instead of 8.0
Submitted: 10 Jul 14:40 Modified: 15 Jul 16:47
Reporter: Denis Denis Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version: OS:Ubuntu (18.10)
Assigned to: Bogdan Kecman CPU Architecture:x86

[10 Jul 14:40] Denis Denis
Description:
Mysql 5.7 is still being installed instead of 8.0 after MySQL repository been configured.
While installing .deb APT repo, warning message about using apt-key in scripts appears.

How to repeat:
Follow MySQL 8.0 Fresh Instalation Guide on Ubuntu Cosmic 18.10 from start to "with APT" section.
[15 Jul 16:47] Bogdan Kecman
Hi.

I can't reproduce the issue. Did you run

sudo dpkg-reconfigure mysql-apt-config

all best
Bogdan