Bug #96120 The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception
Submitted: 8 Jul 9:24 Modified: 8 Jul 15:58
Reporter: Md Raja Sarkar Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:8.0 CE OS:Microsoft Windows (Microsoft Windows (Windows 10 Pro))
Assigned to: CPU Architecture:Any (64-bit Operation System, x64-based processor)
Tags: FontsUtils, workbench

[8 Jul 9:24] Md Raja Sarkar
Description:
Description:
After I installed MySQL Workbench by MySQL installer, I launched the workbench main interface successfully. However when I tried to click the "Local instance MySQL56" and it popped up a Unexpected Error window said "The type initializer for 'HtmlRenderer.Utils.FontsUtils' threw an exception." and asking me to report this bug to you to fix it. The first time I tried to click "Close" of this error window and trying to click the "Local instance MySQL56" again but nothing happened. I tried other options on main interface, most of them worked fine (Sorry I didn't have time to try everything out). I tried to click the plus button above  "Local instance MySQL56" box which is right behind "MySQL Connections" tittle. In that window I clicked "Configure Server Management..." button and following the guide I saw it said connection testing was done and everything was OK.

How to repeat:
How to repeat:
You can try to go through it again as what I said in "Description"

Suggested fix:
I guess the problem is from the font util since the tittle of exception looks like it is. Therefore I will try to re-install MySQL Server to see whether there is any option relating to font util and I will choose it carefully.
[8 Jul 15:58] Miguel Solorzano
Thank you for the bug report. I could't repeat on my side on Windows 10 Pro and server version 5.6 and 8.0.16. Are you tried to re-install using the repair option?. Thanks.