Bug #96060 mysql 8.0.16 Compilation fails at make stage on fedora 30
Submitted: 2 Jul 2019 8:51 Modified: 9 Jul 2019 14:03
Reporter: lalit Choudhary Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:8.0.16 OS:Fedora (5.1.12-300.fc30.x86_64)
Assigned to: CPU Architecture:Any

[2 Jul 2019 8:51] lalit Choudhary
Description:
# uname -a
Linux localhost.localdomain 5.1.12-300.fc30.x86_64 #1 SMP Wed Jun 19 15:19:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linu

# cmake .. -DWITH_SSL=system -DCMAKE_BUILD_TYPE=Debug -DWITH_DEBUG=1 -DWITH_VALGRIND=1 -DWITH_RAPID=ON -DBUILD_CONFIG=mysql_release -DFEATURE_SET=community -DWITH_EMBEDDED_SERVER=OFF  -DDOWNLOAD_BOOST=1 -DWITH_BOOST=./

make -j 2

/mysql/mysql-8.0.16/router/src/http/src/kdf_pbkdf2.cc: In static member function ‘static std::vector<unsigned char> Pbkdf2::salt()’:
/mysql/mysql-8.0.16/router/src/http/src/kdf_pbkdf2.cc:53:18: error: comparison of integer expressions of different signedness: ‘std::vector<unsigned char>::size_type’ {aka ‘long unsigned int’} and ‘int’ [-Werror=sign-compare]
   53 |   if (out.size() > std::numeric_limits<int>::max()) {
      |       ~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
cc1plus: all warnings being treated as errors
make[2]: *** [router/src/http/src/CMakeFiles/http_auth_backend_lib.dir/build.make:89: router/src/http/src/CMakeFiles/http_auth_backend_lib.dir/kdf_pbkdf2.cc.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:11897: router/src/http/src/CMakeFiles/http_auth_backend_lib.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
make[1]: *** Waiting for unfinished jobs....
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_extension.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_field.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_file.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_generator.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_helpers.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_map_field.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_message.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_message_field.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_oneof.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/objectivec/objectivec_primitive_field.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/php/php_generator.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/plugin.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/plugin.pb.cc.o
[ 31%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/python/python_generator.cc.o
[ 32%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/ruby/ruby_generator.cc.o
[ 32%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/subprocess.cc.o
[ 32%] Building CXX object extra/protobuf/protobuf-3.6.1/cmake/CMakeFiles/libprotoc.dir/__/src/google/protobuf/compiler/zip_writer.cc.o
[ 32%] Linking CXX static library libprotocd.a
[ 32%] Built target libprotoc
make: *** [Makefile:163: all] Error 2

How to repeat:

# cmake .. -DWITH_SSL=system -DCMAKE_BUILD_TYPE=Debug -DWITH_DEBUG=1 -DWITH_VALGRIND=1 -DWITH_RAPID=ON -DBUILD_CONFIG=mysql_release -DFEATURE_SET=community -DWITH_EMBEDDED_SERVER=OFF  -DDOWNLOAD_BOOST=1 -DWITH_BOOST=./

make -j 2
[2 Jul 2019 9:38] lalit Choudhary
mysql 8.0.16 Compilation fails at make stage on fedora 30
[2 Jul 2019 16:26] Terje Røsten
Hi!

Try to add

 -DMYSQL_MAINTAINER_MODE=0 

as workaround.
[3 Jul 2019 13:34] Umesh Shastry
Hello Lalit,

Thank you for the report.
Verified as described on Fedora 30.
Please try the workaround as suggested by terje in his earlier note.

regards,
Umesh
[9 Jul 2019 14:04] Tor Didriksen
duplicate of bug#95585