Bug #95992 nysqldump8.0 not compatible with mysql-server5.7
Submitted: 26 Jun 2019 7:41 Modified: 26 Jun 2019 7:57
Reporter: chaoquan quan Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: mysqldump Command-line Client Severity:S3 (Non-critical)
Version:8.0.16 OS:Any
Assigned to: CPU Architecture:Any

[26 Jun 2019 7:41] chaoquan quan
Description:
nysqldump8.0 not compatible with mysql-server5.7

How to repeat:
mysqldump -uhotdb_datasource -photdb_datasource -P3307 -h127.0.0.1 test_db  --set-gtid-purged=OFF --no-tablespaces --skip-triggers --single-transaction --default-character-set=utf8  --complete-insert --compact --skip-tz-utc> dump.sql
mysqldump: [Warning] Using a password on the command line interface can be insecure.
mysqldump: Couldn't execute 'SELECT COLUMN_NAME,                       JSON_EXTRACT(HISTOGRAM, '$."number-of-buckets-specified"')                FROM information_schema.COLUMN_STATISTICS                WHERE SCHEMA_NAME = 'db252' AND TABLE_NAME = 'a';': Unknown table 'column_statistics' in information_schema (1109)
[26 Jun 2019 7:50] MySQL Verification Team
Hello chaoquan quan,

Thank you for the report.
Imho this is duplicate of Bug #89825, please see Bug #89825, please see Bug #89825

regards,
Umesh
[26 Jun 2019 8:52] Bharathy Satish
8.0 mysqlpump is compatible with 5.7 server. Can we try mysqlpump to take a dump.