Bug #95932 mysqld got signal 11
Submitted: 23 Jun 14:37 Modified: 25 Jun 8:51
Reporter: kimi mike Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:5.5 OS:Linux (own os based on linux 64bit)
Assigned to: Bogdan Kecman CPU Architecture:x86
Tags: crash, ibdata and log file wrong

[23 Jun 14:37] kimi mike
Description:
190618 02:00:50 mysqld_safe Number of processes running now: 0
190618 02:00:50 mysqld_safe mysqld restarted
190618  2:00:50 [Warning] Ignoring user change to 'mysql' because the user was set to 'root' earlier on the command line

190618  2:00:50 [Warning] You need to use --log-bin to make --binlog-format work.
190618  2:00:50 [Note] Plugin 'FEDERATED' is disabled.
190618  2:00:50 InnoDB: The InnoDB memory heap is disabled 
190618  2:00:50 InnoDB: Mutexes and rw_locks use GCC atomic builtins
190618  2:00:50 InnoDB: Compressed tables use zlib 1.2.3
190618  2:00:50 InnoDB: Using Linux native AIO
190618  2:00:50 InnoDB: Initializing buffer pool, size = 2.0G
190618  2:00:50 InnoDB: Completed initialization of buffer pool 
190618  2:00:50 InnoDB: highest supported file format is Barracuda.
InnoDB: Log scan progressed past the checkpoint lsn 28587984 
190618  2:00:50  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer... 
InnoDB: Doing recovery: scanned up to log sequence number 28589869
190618  2:00:50  InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 
InnoDB: Apply batch completed
190618  2:00:50  InnoDB: Waiting for the background threads to start
190618  2:00:51 InnoDB: 1.1.8 started; log sequence number 28589869
190618  2:00:51 [Warning] 'user' entry 'root@localhost.localdomain' ignored in --skip-name-resolve mode.
190618  2:00:51 [Warning] 'user' entry '@localhost.localdomain' ignored in --skip-name-resolve mode.
190618  2:00:51 [Warning] 'proxies_priv' entry '@ root@localhost.localdomain' ignored in --skip-name-resolve mode.
190618  2:00:51 [Note] Event Scheduler: Loaded 0 events
190618  2:00:51 [Note] /tools/mysql/bin/mysqld: ready for connections.
Version: '5.5.15-log'  socket: '/tmp/mysql.sock'  port: 3306  MySQL Community Server (GPL)
190618  2:06:02 - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=8388608
read_buffer_size=2097152
max_used_connections=11
max_threads=500
thread_count=10
connection_count=10
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 5133883 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x72b8550
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0x7f3f608e6e68 thread_stack 0x30000
/tools/mysql/bin/mysqld(my_print_stacktrace+0x39)[0x798989]
/tools/mysql/bin/mysqld(handle_segfault+0x380)[0x4fde40]
/lib64/libpthread.so.0[0x3ca3a0f710]
/tools/mysql/bin/mysqld(hp_movelink+0xb)[0x918a5b]
/tools/mysql/bin/mysqld(hp_write_key+0x22e)[0x91ba0e]
/tools/mysql/bin/mysqld(heap_write+0x9b)[0x91bdcb]
/tools/mysql/bin/mysqld(_ZN7ha_heap9write_rowEPh+0x43)[0x917d13]
/tools/mysql/bin/mysqld(_ZN7handler12ha_write_rowEPh+0x5c)[0x66db2c]
/tools/mysql/bin/mysqld[0x5a41e4]
/tools/mysql/bin/mysqld[0x59283b]
/tools/mysql/bin/mysqld(_Z10sub_selectP4JOINP13st_join_tableb+0x86)[0x597ec6]
/tools/mysql/bin/mysqld[0x59d6dd]
/tools/mysql/bin/mysqld(_ZN4JOIN4execEv+0x4ef)[0x5b139f]
/tools/mysql/bin/mysqld(_ZN18st_select_lex_unit4execEv+0x1f1)[0x5deea1]
/tools/mysql/bin/mysqld(_Z21mysql_derived_fillingP3THDP3LEXP10TABLE_LIST+0x168)[0x559b88]
/tools/mysql/bin/mysqld(_Z20mysql_handle_derivedP3LEXPFbP3THDS0_P10TABLE_LISTE+0x69)[0x559989]
/tools/mysql/bin/mysqld(_Z20open_and_lock_tablesP3THDP10TABLE_LISTbjP19Prelocking_strategy+0x125)[0x541955]
/tools/mysql/bin/mysqld[0x5715c5]
/tools/mysql/bin/mysqld(_Z21mysql_execute_commandP3THD+0x226a)[0x576c4a]
/tools/mysql/bin/mysqld(_Z11mysql_parseP3THDPcjP12Parser_state+0x15a)[0x5790ba]
/tools/mysql/bin/mysqld(_Z16dispatch_command19enum_server_commandP3THDPcj+0x1321)[0x57ac31]
/tools/mysql/bin/mysqld(_Z24do_handle_one_connectionP3THD+0x167)[0x60f0b7]
/tools/mysql/bin/mysqld(handle_one_connection+0x54)[0x60f124]
/lib64/libpthread.so.0[0x3ca3a079d1]
/lib64/libc.so.6(clone+0x6d)[0x3ca32e88fd]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (0x7f3f20004c00): SELECT  dst_ip, SUM(total_stream) AS total_stream, SUM(up_stream) AS up_stream, SUM(down_stream) AS down_stream  FROM (  SELECT  dst_ip, SUM(oct_upstream + oct_downstream) AS total_stream, SUM(oct_upstream) AS up_stream, SUM(oct_downstream) AS down_stream  FROM t_monitor_user_app_if_zone_critical_60min_0_1560556800 WHERE timestamp >= 1560708343 AND timestamp <= 1560794743   AND src_user = 0  GROUP BY dst_ip  UNION ALL  SELECT  dst_ip, SUM(oct_upstream + oct_downstream) AS total_stream, SUM(oct_upstream) AS up_stream, SUM(oct_downstream) AS down_stream  FROM t_monitor_user_app_if_zone_critical_60min_0_1560643200 WHERE timestamp >= 1560708343 AND timestamp <= 1560794743   AND src_user = 0  GROUP BY dst_ip  UNION ALL  SELECT  dst_ip, SUM(oct_upstream + oct_downstream) AS total_stream, SUM(oct_upstream) AS up_stream, SUM(oct_downstream) AS down_stream  FROM t_monitor_user_app_if_zone_critical_60min_0_1560729600 WHERE timestamp >= 1560708343 AND timestamp <= 1560794743   AND src_user = 0  GROUP BY dst_ip  UNION AL
Connection ID (thread ID): 350
Status: NOT_KILLED

How to repeat:
maybe large flow makes data large, select crash

Suggested fix:
none
[25 Jun 8:51] Bogdan Kecman
Hi,

This version of MySQL is rather old and you really want to upgrade, there are known bugs in this version that can cause it to crash

can't reproduce this on any modern version of MySQL

kind regards
Bogdan