Bug #95748 Exception thrown when using MySqlCommandBuilder.DeriveParameters(MySqlCommand co
Submitted: 12 Jun 2019 8:55 Modified: 12 Jun 2019 9:51
Reporter: zhang zhang Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:8.0.16.0 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[12 Jun 2019 8:55] zhang zhang
Description:
Exception thrown when using MySqlCommandBuilder.DeriveParameters(MySqlCommand command)

I am writing a simple tool to compare stored procedure signatures in
different databases, one of which is MySql. I'm using the
CommandBuilder to derive the parameters and then compare them with our
internal build database. However, whenever I try to derive the
parameters from a stored procedure I'm getting an "Unhandled type
encountered" error. 

How to repeat:
I am writing a simple tool to compare stored procedure signatures in
different databases, one of which is MySql. I'm using the
CommandBuilder to derive the parameters and then compare them with our
internal build database. However, whenever I try to derive the
parameters from a stored procedure I'm getting an "Unhandled type
encountered" error.
[12 Jun 2019 9:51] MySQL Verification Team
Hello zhang zhang,

Thank you for the report.
This is most likely duplicate of Bug #89335, please see Bug #89335

regards,
Umesh