Bug #95508 Parameter is not valid
Submitted: 23 May 2019 21:51 Modified: 24 May 2019 8:19
Reporter: Bryce Morrison Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.16 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: Connection, Parameter, WBBugReporter

[23 May 2019 21:51] Bryce Morrison
Description:
Upon re-establishing a connection (under MySQL Connections), MySQL Workbench 8.0.16 would produce an error:

MySQL Workbench Unexpected Error
MySQL Workbench has encountered a problem
Parameter is not valid.
We are sorry for the inconvenience.....

This continued after restarting Workbench, as well as after restarting Windows 10.

The fix was to uninstall Workbench and reinstall it (the same version, 8.0.16).

How to repeat:
This problem did not seem to have a trigger, but once the problem had surfaced, it did not go away on its own. The uninstallation of MySQL Workbench was the solution.

Suggested fix:
You might evaluate the wb log, although I do not see anything obvious. 
The most recent error messages included the following:

12:31:58 [INF][      Workbench]: UI is up
12:31:58 [WRN][         mforms]: Resource file not found: search_sidebar.png
12:32:02 [INF][      Workbench]: Running the application
12:32:09 [INF][SQL Editor Form]: Opened connection '[our connection name]' to MySQL Community Server (GPL) version 5.7.26
12:32:09 [WRN][         mforms]: Resource file not found: wb-toolbar_nav-back.png
12:32:09 [WRN][         mforms]: Resource file not found: wb-toolbar_nav-forward.png
12:32:09 [WRN][         mforms]: Resource file not found: wb-toolbar_automatic-help-off.png
12:32:09 [WRN][         mforms]: Resource file not found: wb-toolbar_automatic-help-on.png
12:32:09 [WRN][         mforms]: Resource file not found: wb-toolbar_manual-help.png
12:32:09 [WRN][         mforms]: Resource file not found: snippet_sql.png
12:32:09 [WRN][         mforms]: Resource file not found: snippet_sql.png
12:32:09 [WRN][         mforms]: Resource file not found: tiny_undo.png
12:32:09 [WRN][         mforms]: Resource file not found: snippet_use.png
12:32:09 [WRN][         mforms]: Resource file not found: snippet_insert.png
12:32:09 [WRN][         mforms]: Resource file not found: snippet_clipboard.png
12:32:09 [ERR][      Workbench]: Parameter is not valid.
Exception = System.ArgumentException
Message = Parameter is not valid.
FullText = System.ArgumentException: Parameter is not valid.
   at System.Drawing.Bitmap..ctor(String filename, Boolean useIcm)
   at TriangleNodeControl..ctor()
   at MformsTree.AddColumn(TreeColumnType type, String name, Int32 initial_width, Boolean editable)
   at MySQL.Forms.ViewEventTarget.HandleMouseClick(Object sender, MouseEventArgs e)
   at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
[24 May 2019 8:19] Miguel Solorzano
Thank you for bug report. Duplicate of bug https://bugs.mysql.com/bug.php?id=79224 and others and the workaround is to reinstall.