Bug #95358 MySQL Workbench - Schema entries could not be fetched
Submitted: 13 May 2019 15:17 Modified: 13 May 2019 16:22
Reporter: Patrick Loftus Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.16 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:Any
Tags: schema, workbench

[13 May 2019 15:17] Patrick Loftus
Description:
When expanding a schema, MySQL Workbench reports that tables/view/stored procedures/functions could not be fetched.  If you further open one of those categories, the data is available, so the could not be fetched message is in error.  Clicking Refresh All does not update/fix.  The initial expansion and subsequent Refresh All causes an error to be logged in Output.

At the same time, the Output window displays:

11:10:07	Error loading schema content	Error Code: 1146 Table 'performance_schema.user_variables_by_thread' doesn't exist	

11:10:22	Error loading schema content	Error Code: 1146 Table 'performance_schema.user_variables_by_thread' doesn't exist	

How to repeat:
1. Expand a SCHEMA.
2. See status for Tables/View/Stored Procedures/Functions says could not be fetched.
3. Expand Tables.
4. See tables are available and can be manipulated without error.
5. Same for views/sp/functions.

Suggested fix:
Properly display the status of the schema entries.  Or, please address the error log display and how to remedy (settings, etc.)
[13 May 2019 16:22] MySQL Verification Team
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=95335.
[9 Oct 2019 9:19] Matthias Maier
Seems to be only the case if the user has not the right SHOW DATABASES. But it is still a bug since other DBA-Tools work correctly and even the Workbench can display the tables if you click on the arrow.
[30 Jun 2020 10:37] Joaquim Seixas
Hello,

This is not a but. It's a issue in your schema. By example, you have a TABLE A and you have created views of the data of the TABLE A. After, you delete the table and you forgot to delete the views of the TABLE A! Immediatly you received the message 'could not be fetched'.

Regards.
[30 Jun 2020 13:59] Matthias Maier
@Joaquim Seixas: You misunderstood the problem. It is not about ALTERING or DELETING anything in the database, it is just a problem of displaying in the workbench.
[28 Sep 21:36] Paolo Laurenza
I was adding and removing table columns and i needed to update a view. when i use "copy to clipboard > select all statement" i couldn't get the new coloumns. So i try to disconnect and reconnect but error persisted, so I close the workbench and it crash after some time. I sent you the error. After that i get the reported bug only on the DB iwas working on . Hope it helps, i was on an Ubuntu WMWare WM. The log comes from Roma at local 23:00 pm approximately.